Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running an application on my Macbook Pro. Since yesterday I can't see the application's main window. Its icon is showing in the doc and its options are showing in the top menu bar on the desktop. The program is running normally in all other respects as far as I can tell (it's an audio sampler which I am triggering via an external pedal, so I can tell its working).

The window did show up once in Expose but now it is not showing up there either (no idea why). I've tried adding the application to every space in 'Spaces' and also removing the preferences file but neither of those helped. I have also re-installed the application.

How can I "find" this window?

share|improve this question

3 Answers 3

up vote 8 down vote accepted

Open AppleScript Editor and insert the following script code, replacing Safari by your application's name:

tell application "System Events"
    tell process "Safari"
        repeat with wnd in every window
            set position of wnd to {40, 40}
        end repeat
    end tell
end tell

Check System Preferences » Displays if you have multiple displays connected (could be virtual) and whether a button Gather Windows is available. Click it.

You could also try Mercury Mover, a software that allows you to control window movements using the keyboard.

share|improve this answer
Brilliant! I ran the script (replacing the name as described) and initially got the following error - "System Events got an error: Access for assistive devices is disabled." After enabling access for assistive devices via the Univseral Access pane in System Preferences I ran the script again and - viola - up popped the window. Thanks Daniel, you really helped me out here! – S White Aug 20 '12 at 10:15

I encountered a similar problem once when playing with Multiple Displays. I resolved it like this:

  1. I reduced the resolution of the display to a resolution lower than my current one causing the window to be auto re-positioned onto a visible portion of the display
  2. I dragged the window to a different position;
  3. I switched the resolution back to the original one showed the window.

You can find the display settings at:

  • System Preferences -> Display -> Resolution
  • Changed to Scaled -> Selected a lower one (e.g. select 1344 x 490 down from 1440 x 900)
share|improve this answer

This is a frustrating problem. I solved this by doing the following:

  1. Select application by moving cursor to pop-up application list OR by hitting F3 & then clicking on it where it appears from its hidden location.

  2. Go to drop-down window that appears at the top of the screen and select View --> Enter Full Screen.

Hope that helps!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.