Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to move all the files on my Western Digital "My Book World" from the "Public" share to a new "Files" share I created. When I tried moving them over the network, the system thought that they were on two different filesystems, and wanted to "copy and delete" instead of simply moving, which would take days.

I've searched for a solution and found out that I could ssh into my "My Book World", and create a new share to the folder "/shares". That way, I could move files from /shares/Public to /shares/Files as fast as possible.

I can access the new global share, but when I try to move the files (either via ssh or via the file explorer), I get a "not enough space on disk" error, which I do not understand.

Is there a problem in the configuration of my share ? I edited /etc/samba/smb.conf, and added at the top :

  path = /shares
  comment =
  browseable = yes
  invalid users =
  valid users = admin
  read list = admin
  write list = admin
  map read only = no
share|improve this question

If you can use SSH to log on to the NAS with administrator privileges, you may me able to move the files using a simple command such as

mv /shares/Public/* /shares/Files
share|improve this answer
I tried but the system answers : mv Public/EPISODES Files/ mv: cannot remove 'Files/EPISODES': Is a directory – Manu Aug 20 '12 at 8:40
up vote 0 down vote accepted

I found what the problem was : each share is mounted at a different point :

~ # df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/md0               1928980    121256   1709736   7% /
/dev/md3                972344     17944    905008   2% /var
/dev/md2             973391744 973391724        20 100% /DataVolume
/dev/ram0                63412        20     63392   0% /mnt/ram
/dev/md2             973391744 973391724        20 100% /shares/Public
/dev/md2             973391744 973391724        20 100% /shares/Download
/dev/md2             973391744 973391724        20 100% /shares/Fichiers

All I needed to do was cd /DataVolume and move files from there !

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .