Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Sky broadband at my home and everything was working perfectly till yesterday.

I was able to connect wireless ly to the internet. Yesterday, my main laptop started showing an Exclamation (!) sign on top of the signal strength indicator. On mouser over, it says "Unidentified Network". However, all my other laptops were still connected to the internet.

Even the same laptop when I boot in Ubuntu works fine. I have tried disabling and enabling the Network adaptor multiple times but nothing changes. On the laptop that works, I logged onto the router interface and it shows the non working laptop as connected but it shows it as "Unknown".

Can anyone please suggest what could possibly be wrong? I checked the TCP/IP settings and they are same across laptops.

share|improve this question

2 Answers 2

Type this is command prompt:

netsh winsock reset

"Enter"

shutdown -r -t 0 /F

This should repair the IP bind. Let me know.

share|improve this answer
    
Hi rOca, Tried the above but the issue still persists. Though, the mouseover now says "No internet access". Earlier, it was saying "Unidentified network". –  Aditya Sehgal Aug 20 '12 at 17:16
    
Did you try to reconnect to the WiFi SSID? Use the Dell software to reconnect instead of Windows one. Let me know if this is successful. Thanks. –  r0ca Aug 20 '12 at 18:54
    
hi. its just not wifi. Ethernet doesn't work either. I tried connecting to WiFI SSID too but doesn't connect. My dell software didn't came with any software to connect. I have always used windows and it always use to work –  Aditya Sehgal Aug 20 '12 at 22:51
    
If you go on the Dell website, over another PC, you might find a Wireless driver that also should come with a connection wizard. That could help. Also, I would try some other stuff like reinstalling the device driver, trying to connect with another user's session or even, try with a Wireless USB adaptor. The last thing I'd do is to reinstall from scratch... long shot tho. –  r0ca Aug 21 '12 at 13:17
    
@roca : have tried almost all of the above (except for Wireless USB adaptor thing). In some other thread, there is a mention of McAfee recent update causing this. Therefore, I tried system restore but still stuck. Am running out of ideas. One thing I did try was to run wireshark and could see dhcp/arp msgs going but nothing else. Sometimes, i see icmpv6 messages going too. Do you think my ip stack is fried? –  Aditya Sehgal Aug 22 '12 at 11:12

Well, all your other network devices are connecting just fine so it's not the AP or your internet connection in general. It's also not likely the hardware because the same laptop works under Ubuntu. My guess would be wireless drivers. Look in the Windows Device Manager to see if there are any new "Unidentified Devices". If there are, then that unidentified device may be your wireless card.

You could try uninstalling and reinstalling the wireless drivers. Dell has a pretty good driver database where you feed in your service tag and it will give you all the drivers for that laptop.

share|improve this answer
    
Even the ethernet doesn't work. I checked as you suggested and there is nothing out of the ordinary. Just to be safe, I un-installed and re-installed drivers but nothing has changed. –  Aditya Sehgal Aug 20 '12 at 23:46
    
The odd thing is everytime it seems to get an IP address. The IP of the DHCP server is also the same as the Gateway. The laptop can get an IP yet cannot talk to the Gateway when I ping it. Running wireshark, I can see arp packets flowing but don't see any ICMP message –  Aditya Sehgal Aug 21 '12 at 0:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.