Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I fear this is probably a very general question answered somewhere else but I didn't see it immediately.

I have a old laptop that someone picked up for free and asked me if I could install a copy of Windows XP. I happily obliged and popped a XP install disk in to get the process started. Windows XP could not recognize that a hard drive was connected to the computer. The BIOS can recognize it, disk checks can scan it and not find any problems, Ubuntu can install just fine, but Windows cannot.

Could this be an issue with proprietary drivers? I swapped out drives with one I know that Windows XP could recognize and had drivers for but still no good. My only other thought is maybe there is a chipset driver missing or some driver for a bus controller? Any other thoughts or suggestions please!

Much Appreciated!

share|improve this question

closed as not a real question by Xavierjazz, afrazier, 8088, Diogo, soandos Aug 21 '12 at 17:41

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

At least do a search. – Xavierjazz Aug 20 '12 at 18:46
Model of laptop might help as well – Dave M Aug 20 '12 at 18:48
Gateway M465-E, and I did do a search numerous times but they did not return with answers specific to my problems – Stephen R Aug 20 '12 at 18:56
erase the hard drive using DBAN, then try install. – Moab Aug 20 '12 at 19:28

Most likely it is something like AHCI mode being enabled in the BIOS for the SATA controller. You say "old", but if the laptop is 5 years old or less (or maybe even older), it probably supports SATA AHCI mode... this usually requires a special driver because Windows XP, released in 2003, came with almost no useful drivers for systems manufactured after 2004.

Try changing AHCI to IDE in the BIOS for one thing. If that doesn't work... well, I was sure that was it. ;)

share|improve this answer
It's about 6 years old I wager after I saw the date stamped on the hard drive (2006). I went to the BIOS looking for the settings for RAID settings and/or the AHCI mode being on but found there weren't any options for those :/ . I tried to install Windows 7 on it just to see (deadly phrase I understand) and it got hung up on issues detecting the hard drive too. – Stephen R Aug 20 '12 at 18:57

Not the answer you're looking for? Browse other questions tagged .