Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm a Mac OS 10.8 newbie, and I would like to seek assistance on how to change the keyboard layout for my Mac.

In my account, chuacw, I have changed the keyboard layout to Dvorak, however, when I boot up the machine, it is still using US keyboard, until I log into my account, at which point, it becomes Dvorak.

I would like the Dvorak layout to be active even before I log into an account.

Does anyone know how I can achieve this?

Thank you

share|improve this question
up vote 2 down vote accepted

The only thing you need to do is check this box below:

Mac OS X System Preferences — Users & Groups, with the "Show Input menu in login window" checkbox checked

That will give you a menu item in the top right corner of your login screen that says the current keyboard layout, and allows you to change it.

Mac OS X Login Screen with the Input Menu activated

As a bonus, you also get an input menu any time you need to type your password to authorize a change to your Mac.

Mac OS X system change authorization dialog box, with Input Menu activated

IIRC, once I chose my keyboard layout of choice (Colemak) in either of these places it remembered it for future logins.


share|improve this answer
Using this you're forced to change the layout every single time you restart, and your preferred layout likely requires scrolling through the entire list each time. – Abhi Beckert Feb 7 at 21:04
  1. Run sudo rm /var/db/.AppleSetupDone; sudo /System/Library/CoreServices/Setup\\ Assistant
  2. Select the input method (custom keyboard layouts have to be in the root library)

  3. Fill in anything in the remaining steps

  4. Delete the created account in the Users & Groups preferences
  5. Change the computer name back in the Sharing preferences

A similar question at Ask Different

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .