Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Win7 when you connect to a new network you're prompted to set it as a Home, Work, or Public connection. Presumably this influences default security settings.

That's all well and good, except for the part that everytime I USB tether my smartphone Win7 comes up with a new dialogue. I think I'm up to generic connection 25 or something? It's getting ridiculous.

Is there anyway to get Win7 to remember the phone tether as ONE connection only?

share|improve this question
    
You need to tell us what smartphone you're using (although just the operating system and OS version may be enough). Also, what method are you using to tether? RNDIS? –  allquixotic Aug 21 '12 at 5:11
    
BTW, I'm having the same problem with USB tethering on Android on a Motorola Droid Razr Maxx. I just checked the box to make Windows automatically allocate every "new network" as a Public network, and the prompts stopped coming up. Public is the most secure option anyway as it disables file sharing. I'd be interested in the answer to the question though, as far as getting it to recognize it as the same network each time. It may be tied to the MAC address though, so if the phone is generating a new RNDIS MAC address on each connect, there may not be much we can do about it. –  allquixotic Aug 21 '12 at 5:13
    
@allquixotic, I'm using a Samsung Note (i7000) running a daily build of Cyanogen, but this problem has been present with multiple phones running Android with Win7. It is certainly not unique to the handset. Every single time I USB tether I get prompted to denote a new connection type and I am unwilling to give up and go "all public" as you have. –  Andrew Heath Aug 21 '12 at 5:18

4 Answers 4

Open Network and Sharing center, click on the icon of the active tethered network, click on merge or delete network locations to delete networks not in use.

share|improve this answer

You can try this if you don't mind the network icon not showing that you're connected.

  1. Open Registry Editor (regedit.exe).
  2. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}.
  3. There are subkeys numbered 0001 to 0019. Look in each subkey in descending order (start from 0019) for the one with DriverDesc value having your smartphone's RNDIS driver name (same name shown in your Network Connections view as the "Connect using" value).
  4. Once located, in the right side, right-click an empty area and select New > DWORD (32-bit) Value.
  5. Enter the name as *NdisDeviceType (remember to include the asterisk sign * in front).
  6. Edit the newly created DWORD value and enter the value data as 1 (Base choice doesn't matter). Click OK.
  7. Once done, in your Network Connections view, disable the network device, and enable it after a few seconds.

You will no longer get a prompt asking for network location whenever you connect your smartphone, but you will still get the prompt when connecting other devices.

Important Note: When you are only connected to your smartphone, your computer's network icon will continue to show that you are not connected to any network. However, the internet will still work fine.

Source: Windows 7 starts a new network every...: Apple Support Communities

share|improve this answer
  1. Open Network & Sharing Center

  2. Change adapter settings

  3. Right click (on your tethered "Remote NDIS based Internet Sharing Device", in my case its "LAN-Huawei-USB")

  4. Status

  5. Details

  6. Copy the IPv4 Address, Subnet Mask, Default Gateway & DNS Servers (in my case it's- ipv4: 192.168.42.11, subnet: 255.255.255.0, gateway: 192.168.42.129, dns servers: 208.67.222.222 & 8.8.8.8)

  7. again Right click (on your tethered "Remote NDIS based Internet Sharing Device", in my case its "LAN-Huawei-USB")

  8. Properties

  9. Highlight "Internet protocol version 4 (TCP/IPv4)

  10. Properties

  11. Use the following IP address:

  12. enter what you copied earlier from STATUS here

  13. OK

  14. close all windows

Now your computer will stop creating Networks, mine has stopped at "Network 14"

share|improve this answer

Here's how one bridges 2 internet connections in Windows 7

A network bridge is software or hardware that connects two or more networks so that they can communicate. You can create only one network bridge on a computer, but one bridge can handle any number of network connections.

Open Network Connections by clicking the Start button Picture of the Start button, and then clicking Control Panel. In the search box, type adapter, and then, under Network and Sharing Center, click View Network Connections.

Hold down the Ctrl key and select each internet network connection that you want to add to the bridge.

Hold down ALT to reveal Advanced Menu and click Bridge Connections. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

You should now have a new network type named "Network Bridge" created.

Now Bridge the internet connection from your android phone with your alternate connection you usually use as described above.

Leave this internet bridge on your system.

Assuming one would use USB tether internet where home connection is unavailable, when you now connect your phone, instead of showing it as a NEW CONNECTION EACH TIME, Windows will directly recognize it from the internet bridge. This will stay so even after you restart your system and you are saved from registry tweaks.

share|improve this answer
    
This is a bit offtopic - I don't think it answers the parent question. –  Arthur Mar 18 at 19:55
    
Dear Arthur, there are always solutions to whys but no one is interested in answers to why this world was created or why windows behaves like this, if that's what your comment regarding being offtopic means –  maxmumbai1234 Mar 18 at 20:25

protected by random Mar 19 at 2:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.