Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We are using VMware vSphere 5.0 infrastructure to run our VMs.

Our VMs consist of desktops (multiple versions of Windows) that need a soundcard installed.

Is there any solution for achieving this ?

share|improve this question

2 Answers 2

You can do either one of two things:

  • Install physical USB sound devices and use USB passthrough
  • Connect to the VMs via Remote Desktop and enable audio forwarding
share|improve this answer
    
Thanks. A USB passthrough is attached at the vSphere level? If so, is it shared among all VMs or can be used only by a particular machine? –  liortal Aug 21 '12 at 11:08
    
Only one VM can use it at a time. So you'd need as many such devices as you have VMs. You'd also need to ensure that your motherboard actually supports it (Look at the DirectPath IO settings) –  PhonicUK Aug 21 '12 at 11:48

Enabling sound for Remote Desktop Protocol in a Windows virtual machine (1004839) Purpose This article provides steps for enabling sound for Remote Desktop Protocol (RDP) in a Windows virtual machine. Resolution To enable sound in a virtual machine when connected using RDP:

Windows 2003:

Click Start > Run, type services.msc, and click OK.
Change the Windows Audio service to Automatic and start the service.
Click Start > Settings > Control Panel > Administrative Tools.
Click the Terminal Services Configuration section.
Double-click RDP-TCP.
Click the Client Settings tab.
Deselect Audio Mapping.

Windows XP and 2008:

Click Start > Run, type mmc, and click OK.
Add the Group Policy Object Editor snapin.
Expand Local Computer Policy.
Expand Computer Configuration.
Expand Administrative Templates.
Expand Windows Components.
Expand Terminal Services.
In Client/Server data redirection, enable Allow Audio Redirection.
Restart the virtual machine.

Windows 7 and 2008 R2:

Click Start > Run, type mmc, and click OK.
Add the Group Policy Object Editor snapin.
Expand Local Computer Policy.
Expand Computer Configuration.
Expand Administrative Templates.
Expand Windows Components.
Expand Remote Desktop Services.
Expand Remote Desktop Session Host.
In Device and Resource redirection, enable Allow Audio and Video Playback Redirection.
Restart the virtual machine.

Windows 2012:

Right-click Start and click Run.
Type mmc, and click OK.
Add the Group Policy Object Editor snapin.
Expand Local Computer Policy.
Expand Computer Configuration.
Expand Policies.
Expand Administrative Templates.
Expand Windows Components.
Expand Remote Desktop Services.
In Device and Resource redirection, enable Allow Audio and Video Playback Redirection.
Restart the virtual machine.

Windows 2012 R2:

Right-click Start and click Run.
Type mmc, and click OK.
Add the Group Policy Object Editor snapin.
Expand Local Computer Policy.
Expand Computer Configuration.
Expand Policies.
Expand Administrative Templates.
Expand Windows Components.
Expand Remote Desktop Services.
Expand Remote Desktop Session Host.
In Device and Resource redirection, enable Allow Audio and Video Playback Redirection.
Restart the virtual machine.

Notes:

Verify on the guest OS > Options > Local Resources.

Settings under Remote audio settings, the option Play on this computer should be enabled.

Windows XP may require the policy to be set to Enable.
Windows 2008 may require the policy to be set in User Configuration\Administrative Templates\Windows Components\Terminal Services.
Windows 2008 R2 requires Windows Audio Service to be started automatically.

To ensure that this service starts automatically:
    Click Start > Run, type services.msc and click OK.
    Change the service to start in Automatic mode.

Additional Information For more information, see the Microsoft Knowledge Base articles 818465 and 886199.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.