Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm unable to connect default metro applications (Mail, Calendar and Poeple) to corporate Exchange server.

I run the app and in setting select Add account > Outlook account. I fill the email and the password and after about half a minute I receive:

We couldn't find settings for email@domain.com. Provide us with more info and we'll try connecting again.

What more info do I need to provide? I'm not sure I know the domain, server or user name - I'm using only corporate email to log everywhere and it is enough. Moreover I'm also running Outlook 2013 Preview on the same box and it connected with just an email and password without any problem.

I'm running Windows 8 Enterprise RTM from a flash drive (Windows-To-Go) and I'm logging with personal Microsoft account to computer.

share|improve this question

3 Answers 3

I had this same issue which was caused by the server using a self signed ssl certificate.

You can add an exchange account using a self signed ssl certificate to the Windows 8 Mail app. There is a lot of information on the internet indicating the contrary, however you CAN do it.

It requires installing the certificate using MMC (not cermgr) to [Console Root\Certificates (Local Computer)\Trusted Root Certification Authorities\Certificates].

  1. You must download the certificate to your Windows 8 device. If you have access to Outlook Web Access you can browse that website, click the certificate in the browser and save as a p7b file.
  2. From the desktop run MMC.exe
  3. Choose File->Add/Remove Snap-in...
  4. Choose Certificates, then click the Add button, and OK.
  5. Navigate to [Console Root\Certificates (Local Computer)\Trusted Root Certification Authorities\Certificates].
  6. Right click the "Certificates" folder, select All Tasks->Import...
  7. Choose "Local Machine", Next.
  8. Browse to the certificate file you saved on your device and click Next.

You might be able to install the certificate to a different folder however I have not tested that.

You can probably do the same thing by double clicking (opening) the p7b file, right clicking the certificate and selecting "Install Certificate...", then installing into Local Machine.... Although I have not tested that.

Once you have done this you will be able to add your Exchange account to Main/People/Calendar.

I have tested this on a Windows RT device and it does work.

Update: There are a couple other ways to install the certificate so if you are familiar with those you can choose the method you are comfortable with.

Also if you have a failover Exchange site with a self signed certificate, be sure to install the certificate from that server as well.

share|improve this answer
    
Yep, this is the correct way to do it - indeed, this is similar to the way you need to do it on Windows Phone 7. Another key point is that some Exchange servers will then want to enforce certain security constraints on the system, including not using picture passwords, password strength, etc. –  Zhaph - Ben Duguid Nov 6 '12 at 14:37

I believe the issue is centered around self signed ssl certificates on the exchange server. We have this issue and almost all people I have seen with this issue also have self signed certificates. Once a certificate was installed on the server that could be authenticated over the internet then the problem seemed to disappear.

The easiest way to check if you have this issue is to go to www.testexchangeconnectivity.com which is a website provided by microsoft to check whether your exchange server is working correctly from an external source. Run the check using exchange activesync and if you have an issue with the certificate not being able to be authenticated, then you will probably have issues with the windows 8 mail app. This app does not seem to check the Trusted root certificate authority certificates on the local machine so is probably the reason why this fails.

share|improve this answer

In your Outlook webmail click on Options or See all options and look for the link that says Settings for POP, IMAP, and SMTP access....

Webmail options

There you can find the name of the server that I believe Mail is looking for.

See the short video on this page that walks through the exact steps.

share|improve this answer
    
That will allow me to connect through IMAP - I just tested it through Mail application and it works but other two applications (Calendar and People) do not offer IMAP connection - they need something called "Outlook" account (it covers Office 365, Exchange and Outlook.com). Also Mail application is no ready to work with IMAP folders like Contacts and Calendar. –  Ladislav Mrnka Aug 21 '12 at 12:24
    
For me, this dialog is common across Calendar, Mail and People. In any of the app's Settings charm (Win+c), I click Accounts, Add account, Outlook, Show more details to get there. –  Louis Aug 21 '12 at 12:34
    
Yes and this doesn't work for me. –  Ladislav Mrnka Aug 21 '12 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.