Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Microsoft Wireless Keyboard 3000 v2.0 that was bought paired with a Microsoft Wireless Mouse 5000. They're both Bluetooth and use the same receiver.

The keyboard no longer works. The receiver is fine, as the mouse still works. The keyboard is still detected by Windows when the receiver is plugged in. The batteries have been replaced. There are no on/off switches on the keyboard or mouse, and no re-sync button on them or the receiver. Results are the same when using the receiver in a different USB port, or on a different machine.

Anything else I might try to fix this, or should I hold a funeral for the keyboard?

share|improve this question
1  
Update to the latest drivers. Just the reinstall might fix it. Also check for any stuck keys. – CharlieRB Aug 21 '12 at 15:49
up vote 4 down vote accepted

I too had this same problem with my 3000 keyboard, because the transmitter is a nano transmitter there is no re*syn* capability (no mouse with this keyboard...the keyboard IS available without the mouse combo).

I contacted Microsoft and explained the situation and seeing as the keyboard has a 3 year warranty, they replaced it right there & then, no questions asked. all I had to do was supply them with the model#, serial# and where I purchased the item from. I was pleasantly surprised.

share|improve this answer
    
Wow did it in under 20 min – cgatian Jun 5 '14 at 0:31

I had this issue also. In my case, the problem turned out to be the "Turn on repeat and slow keys" setting.

Control Panel\All Control Panel Items\Ease of Access Center\Set up Filter Keys

share|improve this answer
    
Could you possibly re-work your answer? it reads more like a question than an answer. – suspectus Dec 30 '14 at 0:10
    
That's where the setting is located. What should someone do once there? – fixer1234 Dec 30 '14 at 4:25

I just had the same problem, was about to give up and throw a perfectly good keyboard in the round tin when I found this 'Filter Keys' post.

Well done, it fixed the problem for me with Windows 8.1 on Surface Pro.

On Win8.1, probably similar for Win10. Go to Settings, Ease of Access, Keyboard ... change the 'Filter Keys' to 'off' This setting states it is to 'ignore or slow down brief or repeated keystrokes and adjust keyboard repeat rates' ... immediate result, keyboard was working in 1-2 seconds. In my case like above the mouse had always worked, the keyboard had been in the cupboard for about a year and I was trying to use it with a new system.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .