Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Background

I replaced som XP computers with Win 7 computers. We have a HP Laserjet 1320dn printer attached to the LAN. The XP computers could print to it from Word in duplex mode without any issues.

Problem

The Win 7 computers downloaded a full set of drivers including a "HP Laserjet 1320 PCL5" driver. However using this, Word's page footers cause extra pages to be printed with just a letter or so at a time from the footer. Some other apps have similar issues.

I also have an ancient Laserjet 1200 attached to the LAN via a Jetdirect box and that works just fine. So I don't think the problem is with Word (the computers came with Word 2010 starter).

What I tried

I wrangled the control-panel new printer dialogue into using a "HP Laserjet 2100 PS" driver for the HP Laserjet 1320dn. Now my Word documents print as they should. However I don't have a duplex option on the print dialogue. I'd really like to be able to use duplex printing.

Question

Windows used to have a Universal Postscript driver that read a Postscript Printer Definition (PPD) file to make the printer's features available (tray choice, duplex etc). I can't see any way to do this in Windows 7. Is there a way?

Is there any other way I can get Windows 7 Home Premium 64-bit to print properly to a HP Laserjet 1320dn and have access to all it's major features?


Addendum:

My page in Word looks like this:

+--------------------+
|  aa      bb    cc  |
|                    |
| lorem ipsum dolor  |
|                    |
...
|                    |
|  pp     qq     rr  |
+--------------------+

The headers and footers were inserted using Insert -> header -> blank (3 column).

When printed I get

1 page with aa, bb, cc, pp in correct position (no other text)
1 blank page
1 page with qq in correct position (no other text)
1 blank page
1 page with rr in correct position (no other text)
1 blank page
1 page with lorem ipsum dolor in correct position (no headers or footers)

If I use a Laserjet 2100 driver I get 1 correct page.

share|improve this question
    
Have you tried the HP Universal Printing PCL 6 driver? –  jdh Aug 21 '12 at 16:52
    
@jdh: I tried the HP Universal Printing PCL 5 driver (same problem with spurious pages containing small parts of footer) I can't find a HP Universal Printing PCL 6 driver in the list that Windows 7 downloaded. –  RedGrittyBrick Aug 21 '12 at 17:02
    
    
@jdh: Please add that as an answer - I downloaded the "HP Universal Print Driver for Windows PostScript" from that page and it solved my problem completely. –  RedGrittyBrick Aug 22 '12 at 10:40

2 Answers 2

up vote 1 down vote accepted

Try the HP Universal Printing PCL 6 driver from this hp download page. We've had good luck with this version on windows 7 with various HP printers at our site.

share|improve this answer

From what I've found and read, this is a know and common issue. You can try the following which was found in HP's Support Forum.

  1. Start > Devices and Printers >
  2. Right click on hp LaserJet 1320 PCL 5 > Printer Properties
  3. Device Settings Tab > Scroll down to Installable Options > Duplex Unit (for 2 sided printing)
  4. Use the pull down to change from "Not installed" to "Installed"
share|improve this answer
    
My problem is that when I print a Word document with footers using the "HP Laserjet 1320 PCL5" driver, I get about six pages printed instead of one. I'll add and addendum to the Q. –  RedGrittyBrick Aug 21 '12 at 18:34
    
Sorry. Guess I kind of got hung up on the duplex issue itself. –  CharlieRB Aug 21 '12 at 18:37
    
Actually when I get back to the printer location I'll try that with the 2100 driver. It may be a solution. –  RedGrittyBrick Aug 21 '12 at 18:42
    
The 2100 driver doesn't provide a Device Settings tab. The problem was solved using "HP Universal Print Driver for Windows PostScript" from HP –  RedGrittyBrick Aug 22 '12 at 10:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.