Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed the chrome extension Speed Dial 2. Although I ticked the checkbox "Allow in incognito" under chrome://chrome/extensions, but it does not work (works in normal mode). When a new tab is opened, the standard

"You are in incognito mode bla bla ..." is displayed.

If I manually enter the url

chrome-extension://jpfpebmajhhopeonhlcgidhclcccjcik/newtab.html

it does not work either (This works in NON-incognito mode!)

Thank you in advance for any suggestions how to solve this.

share|improve this question

2 Answers 2

This is what the Speed Dial 2 page has:

Speed dial 2 is fast and clean extension for your favorite pages and quick access to your apps, bookmarks and browsing history.

and

Speedial2 keeps track of your daily routines and remembers which pages you visit in the morning, afternoon, evening and night. These are afterwards highlighted to distinct pages you often visit at the current part of a day.

I would imagine that these features are expressly what are excluded when one chooses the incognito mode. In other words, the Speed Dial 2 features are contrary to what the incognito mode achieves.

share|improve this answer
    
The main feature of any speed dial is to visualise bookmarks in form of clickable thumbnails. I do not see why this should not be used in incognito mode. I use incognito mode by default, because chromium does not keep track of history and cookies in incognito mode. This way I do not have to bother with installing extensions to clear history etc ... –  MCH Aug 21 '12 at 18:49
    
But this particular speed dial does more according to the quotes I found on the page. It's not just about bookmarks. It specifically tries to record history. And the new tab page is based not just on bookmarks but their frequency of use which implies recording visits to pages. Again incompatible with incognito mode. –  user151227 Aug 21 '12 at 19:02

I found the solution.

To enable ANY chrome extension in incognito mode:

  1. Install the extension via the chrome store
  2. Copy the extension to some other place: cp -r ~/.config/chromium/Default/Extensions/jpfpebmajhhopeonhlcgidhclcccjcik/1.6.0.9_0 ~
  3. Go to the location of the copy: cd ~/1.6.0.9_0
  4. Change manifest.json: ... ,"incognito": "split"}
  5. Go to chrome://chrome/extensions, check Developer mode, uninstall the extension via clicking the trash bin, click Load unpacked extension... and select ~/1.6.0.9_0, check Allow in incognito

That's it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.