Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an older MBP running the latest version of Lion. Up until about two or three days ago, I had no problems connecting to my shares on my Windows computer. It is running Windows 7 Ultimate x64.

The actual error message is There was a problem connecting to the server "winmachine".

I can ping the address of my Windows machine from the MBP, and I have it set with a static IP (192.168.200.45). before I could command-k and type smb://winmachine and it would connect straight away. I've also tried replacing winmachine with the static IP address, but I get the same result.

Has anyone experienced this sort of issue or read about a fix somewhere? My GoogleFu seems to be weak right now.

Thanks everyone in advanced!

EDIT:

I found this link after some searching: http://fatwalr.us/2011/08/solution-to-my-smb-connection-problem-in-lion/ but of the majority of the command string is blurred so it doesn't do me much good. So far all I have deciphered is mount -t smbfs < unintelligible > < mac-side share path >

My first attempt was mount -t smbfs //winmachine/multimedia /volumes/multimedia, but that gave an error: mount: realpath /Volumes/Multimedia: No such file or directory

EDIT2:

After fiddling with terminal a bit, I got a different error: mount_smbfs: server connection failed: Cannot allocate memory. So after a bit more Googling, I came across an apple forum thread that had this Microsoft KB article link. I went into the registry on my windows machine, and the registry keyword the KB article indicated was not present. I put it in there, set its value to 15 (it did not have a default value after being created, as the article stated), and rebooted. Once the windows machine came up, I was still unable to connect to it from my MBP using command+k and smb://winmachine. HOWEVER, when I used smb://192.168.200.45 it was able to connect. Strange things, computers.

I am not going to put this as the answer to my question just yet, since the result I am looking for is to be able to connect to it like before with the machine name. For the time being, however, I am happy that I can connect to the shares again.

share|improve this question
1  
+1 for effort :) Have you tried adding winmachine to /etc/hosts? Like so: 192.168.200.45 winmachine –  terdon Aug 22 '12 at 0:58

1 Answer 1

up vote 1 down vote accepted

Ok so I have no idea really what happened and how the problem resolved itself, but a few days later I had no problems connecting to my windows machine with it's name. I made no changes on either machine (updates, ip address, etc), it just decided to start working. I will update if I find out something concrete.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.