Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using a RHEL 5.5 on my PC. I was playing around with chmod and chown. suddenly my home folder become read-only. all the folders in /home/goutham/, where goutham is username, became read-only. I can delete files after turning on system for few seconds, after that it says Permission denied:read only file system. I cant even create folder with sudo mkdir also. Please help me. My os is on /dev/sda3

share|improve this question

migrated from stackoverflow.com Aug 22 '12 at 6:40

This question came from our site for professional and enthusiast programmers.

    
can't you just add wx to you home directory using chmod? – roni Aug 17 '12 at 11:03
    
I did that, but it doesn't work. it says "chmod: changing file system permissions: Read only file system" – gthm geeky Aug 17 '12 at 11:05
    
What is the output of the mount command? – Abrixas2 Aug 17 '12 at 11:07
    
did you mess with the mount? – roni Aug 17 '12 at 11:07
    
Yeah, I tried mount -o remount /home/goutham It dint give any output, but doesn't work. – gthm geeky Aug 17 '12 at 11:09

My problem is Solved after running the command e2fsck -C -p -f -y /dev/sda3 Thanks for everyone.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .