Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a VirtualBox running inside a Debian Squeezy 64 bit machine. For some reason, none of my virtual machines can use the USB ports of the host machine. This error is popping up:

Cant load Host USB Proxy service (VERR_FILE_NOT FOUND). 
The service may not be installed on host machine.

Details:
Result code: NS_ERROR_FAILURE (0x0004005)
Component: Host
Interface: IHost {--a big number here--}
Receptor: IMachine {--another big number here--}

It would be useful for me to use some USB devices inside my VMs (a USB drive and a printer, for example).

Any help?

share|improve this question
up vote 1 down vote accepted

You need to install Virtual Box Guest Additions:

$ sudo apt-get install virtualbox-guest-additions

For a howto, see here.

share|improve this answer
    
Guest additions on the HOST machine? (guest additions are installed on every VM) – Barranka Aug 22 '12 at 17:04
    
@Barranka, I added a link to a howto. You need to install the guest additions package on the host, then install it through VirtualBox, then activate USB controller in the Virtual Machine's settings. – terdon Aug 22 '12 at 17:24
    
@terdon I'm still puzzled why you need to install the VirtualBox Guest Additions on the host machine; even the how-to you linked doesn't mention that. I have a problem similar to the OP (with no error popping up though) and installing the Guest Additions package on the host didn't fix it. – mguassa Aug 13 '15 at 14:37
    
@mguassa See my alternative answer. – Michael Kjörling Dec 24 '15 at 22:17

At least on Debian Wheezy, this problem is fixed by adding your user account to the vboxusers group:

sudo gpasswd -a $(whoami) vboxusers

You will most likely need to log out and back on for the change to take effect. The $(whoami) part will simply be replaced by your username; you can do the replacement manually if you want to, like for example:

sudo gpasswd -a barranka vboxusers
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .