Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been told to try and "port forward" but I'm having a hard time getting that to work. My Belkin router supports virtual servers. I have it configured so that inbound port 8080 goes to private port 80. So now, how do I access my domain on port 8080? Do I configure my A record to point to port 8080 of my ip? If so, what is the syntax?

share|improve this question

migrated from serverfault.com Aug 22 '12 at 17:57

This question came from our site for system and network administrators.

    
Does it work if you specify your external ip directly? like YOURIP:8080? –  monoceres Aug 22 '12 at 18:36
    
It does not, even on my home network which my server is on. Pinging also does not work. –  Devin Aug 22 '12 at 18:40

4 Answers 4

In your web browser, specify the port in the address:

http://www.mydomain.com:8080/

share|improve this answer
    
Unfortunately I've tried that and it doesn't seem to work. Chrome reports a "could not connect" error. When I try to ping it I get an "Unknown host" error. –  Devin Aug 22 '12 at 18:04

Have you spoken with your ISP's support staff? Many ISPs block incoming http traffic because they don't want home customers running web servers from their networks. Some of them which do block will allow you to host for no additional cost if you sign an agreement about what you host, some will only allow if you upgrade to a business class account and some won't allow anything at all.

share|improve this answer
    
I will try to contact them. Isn't the port forwarding masking it as http traffic? I'm not really trying to get around it, I'm just trying to understand how it all works. –  Devin Aug 22 '12 at 18:33
    
No, its not the port that identifies something as http traffic. It's the underlying transport mechanism that carries the data to that specified port. The only significance of ports 80 and 443 are that they are specified as the defaults for http and https traffic. –  BBlake Aug 22 '12 at 20:42

What your experiencing may be normal. A few Residential Gateway Routers fail to resolve DNS to IP for local site resolution. My own being one of them.

share|improve this answer

As was stated above alot of ISPs block port 80, so you have indicated you are using port 8080 instead to get around that. If you open up a terminal and do an ifconfig eth0, which I assume is the interface you are using you are getting some kind of private address such as 192.168.0.x blah blah if not a 10.x.x.x or 172.x.x.x for an IPv4 address, I just want to make sure that on your router for the port-forwarding you are doing an incoming port 8080 - and routing that to your internal web server port 80 with private address of 192.168.x.x whatever is being shown on that ifconfig screen? It's possible your router is also setup to block pings on the WAN interface so a ping may not respond.

Also you say SSH works, is the SSH access to your router or your Linux box?

share|improve this answer
    
The SSH is to my linux box, I can SSH in using either my external IP address or my domain name. And yes, when I do an ifconfig eth0 I get 192.168.2.3. Here are some images of my router settings so you can tell me if I'm being crazy. link –  Devin Aug 23 '12 at 3:58
    
I just disable the WAN ping block, so now I can ping my linux box using both my domain or my external ip address. –  Devin Aug 23 '12 at 4:13
    
Hi Devin, so something that is throwing me off is that you access your Belkin router's web interface through port 8080 i.e. localhost:8080, so maybe try changing the the port forward to 8081 to port 80 on your web server and then try to access your website externally with port 8081? Nice screenshots though very helpful. Also maybe disable DMZ, when I do port forwarding I don't also put the machine on the DMZ. I thought the DMZ was to completely expose a machine on the internet and put it outside of the Firewall. –  j_bombay Aug 24 '12 at 16:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.