Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just did a standard update of all programs on my computer (running Ubuntu 10.04), which included going from Firefox 12 (I think) to 14.0.1. Now I have an extremely strange problem - Firefox appears to be treating both my Shift keys as Alt: i.e. if I press Shift-f, I don't get an F in the textbox, but it selects the File menu; if I press Shift-1, I don't get a !, but nothing else happens; etc.

It's not happening in any other programs that I've seen (I checked terminal, pidgin, chrome). It's happening with both the laptop keyboard and an external USB one. CapsLock works as normal in Firefox; I can also paste the "missing" letters into textboxes without issues (which is how I'm writing this).

I created a new firefox profile with all extensions/plugins/languages disabled, and Shift still doesn't work.

Any ideas for why this could be happening or how I could find out? I've never done much firefox troubleshooting before. I haven't had any luck on google either, so apparently this is not a common problem. I don't know what else to do... (I'm not sure if this is the right place to post this question - suggestions for other sites are welcome too.)

share|improve this question
1  
I'm using the exact same versions of Ubuntu & Firefox to type this, but without the issue you report. Try a different keyboard (USB vs PS/2), and/or remove then install Firefox using Synaptic Package Manager. –  sawdust Aug 22 '12 at 22:45
    
@sawdust - I see the same effect with the laptop keyboard and external USB one. As for reinstalling firefox - do you know if that'll reset my add-ons/preferences/etc? –  weronika Aug 22 '12 at 22:48
    
I think we can rule out any HW as the cause. So a clean install (that would wipeout existing preferences, add-ons etc.) might be a reasonable solution. Granted it's a brute-force approach, but what you're seeing is not an ordinary configurable option. –  sawdust Aug 22 '12 at 22:51
    
@sawdust - i'll try a clean reinstall in a while if i can't come up with anything better... re-doing all the preferences will be pretty painful, though, so i'm putting it off. –  weronika Aug 23 '12 at 0:35
    
You might try disabling all of the add-ons and plugins. There was probably a message about updating plugins when the update to Firefox was complete; you might use the "Add-ons Manager" of Firefox to check/update all of your plugins. –  sawdust Aug 23 '12 at 6:44
show 1 more comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.