Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using search files in Windows 8 (win+f) I don't get expected results. For example, I installed VLC, it's in Program Files (86) folder, and that folder is selected for indexing. Search for files (win+f) gives 0 results.
If I pin to start that exe, then it's found - but I don't want to do this, that's not the point.

Where does it search for files? Is there any way to specify search locations? It doesn't use Indexing Options settings, at least it seams so.

Also, searching from explorer window is kinda slow - I tried entering VLC.EXE in search box (when in c:\ root), and it takes some time to give correct results. It works, but it looks like it doesn't use indexing, rather scan all files/folders, which is slow.

share|improve this question
add comment

3 Answers

The search results are filtered by file type now. If you know the type of file you are looking for use one of the following shortcuts:

⊞ Win+q: search for apps
⊞ Win+w: search for settings
⊞ Win+f: search for other files

share|improve this answer
    
If you read my question, you'll see that I know that –  Hrvoje Aug 29 '12 at 14:50
    
Of course I read your question. My answer is meant to show you that your expectation is misplaced. Win+f searches for non-executables, which explains why it found your shortcut and not VLC.EXE. That you can find it using Explorer tells me Search is working as expected. If you are searching for an executable in WinRT, use Win+q, otherwise continue using Explorer. –  Louis Aug 29 '12 at 14:59
    
But why search with Explorer doesn't use indexing? It's unusable slow, even I added that folder to indexing settings! So basically, from Metro i can't search for files, and Explorer doesn't use Indexing settings. –  Hrvoje Aug 30 '12 at 11:55
add comment

You need to make sure that the directories: c:\Program Files (x86) and c:\Program Files

add to indexing files. By default, they are not. Go to Control Panel --> Indexing

If you add this folder Win+Q works fine.

share|improve this answer
add comment

Go to Control Panel --> Indexing --> Advanced -> there you will find a button called something like rebuild, its forces windows to rebuild the index :D

GL & HF

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.