Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having the same problem as this, but the answer from there doesn't work for me.

Neither in my iMac upgraded from Lion to Mountain Lion (currently at 10.8), nor from a Mac Mini with Lion Server (10.7.4).

I have "Show fast user switching menu as" enabled at "Users & Groups" Login Options, but when I have to login from screensaver, there's no option to switch user.

How can I enable such an option?

EDIT: I think I forgot to mention that we believe (just guessing) that it has to do with network accounts. We use network accounts here, and have that issue. My boss says he could solve this issue at his house's Mac, which don't use network accounts. Does it make a difference?

share|improve this question
    
Have you tried disabling and then re-enabling the settings? Sometimes this can force it. –  user3463 Aug 23 '12 at 17:12
    
I did - no results. –  mgarciaisaia Aug 23 '12 at 21:35

1 Answer 1

up vote 6 down vote accepted

I've run into the same problem. Good news: there's a workaround.

I, too, thought it was tied to having network users. But it's not.. at least not directly.

The problem is that if there aren't two or more local users, it hides the "Switch User" button (because apparently it thinks there's no other user you could possibly switch to). So the workaround is to create a couple of dummy local users. (Just go to the Users & Groups pane in System Preferences and add a few users.)

That will cause the "Switch User" button to appear. And yes, you can use it to switch to network users.

share|improve this answer
    
oh, and I've reported the bug to apple. Radar 12219115. You should file a bug report too (at bugreport.apple.com) because they tend to use duplicate bug reports as a sort of voting mechanism to prioritize fixes. –  Tim Buchheim Sep 1 '12 at 1:14
    
That's it! I'll try to report it, thanks. –  mgarciaisaia Sep 3 '12 at 13:21
    
The bug still exists in Mavericks! –  Lachlan Mar 27 '14 at 5:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.