Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

At boot time, KDM (or XDM or LightDM) fails with Xorg error: no screens found. But a manual restart using service kdm restart seems to fix it.

Xorg errors

[    17.551] (II) Module fbdevhw: vendor="X.Org Foundation"
[    17.551]    compiled for 1.12.3, module version = 0.0.2
[    17.551]    ABI class: X.Org Video Driver, version 12.0
[    17.551] (EE) open /dev/fb0: No such file or directory
[    17.551] (II) RADEON(0): TOTO SAYS 00000000f6df0000
[    17.551] (II) RADEON(0): MMIO registers at 0x00000000f6df0000: size 64KB
[    17.551] (II) RADEON(0): PCI bus 1 card 0 func 0
[    18.832] drmOpenDevice: open result is 9, (OK)
[    18.832] drmOpenByBusid: drmOpenMinor returns 9
[    18.832] drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
[    18.832] (EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.12.0.[dri] Make sure your module is loaded prior to starting X, and
[dri] that this driver was built with support for KMS.
[    18.832] (II) Unloading int10
[    18.832] (II) UnloadSubModule: "vgahw"
[    18.832] (II) Unloading vgahw
[    18.832] (EE) Screen(s) found, but none have a usable configuration.
[    18.832] 
Fatal server error:
[    18.832] no screens found

Additional info

As you can notice, I have an ATI Radeon. Earlier on Debian Squeeze, I was using the proprietary ATI driver. Just switched to the free driver after the upgrade and it has been like this since.

Any idea how to fix this for good?

share|improve this question
up vote 0 down vote accepted

When you "switched" to using the open drivers, did you uninstall fglrx (the proprietary driver)? It overwrites parts of the graphics stack that are depended on by the open source graphics stack. The upgrade might not have replaced all the components that fglrx muddies up.

[dri] This chipset requires a kernel module version of 1.17.0, [dri] but the kernel reports a version of 2.12.0.

A few things to try:

  • Make sure no files such as /etc/modprobe.d/*.conf contain any lines such as blacklist radeon or install radeon /bin/true.
  • Try reinstalling or making sure that the package glx-alternative-mesa is installed and that glx-alternative-fglrx is uninstalled
  • Reinstall/install libgl1-mesa-dri and libgl1-mesa-glx and libglapi-mesa and xserver-xorg-video-radeon and xserver-xorg-core
  • Triple check that you ran the AMD fglrx (Catalyst) uninstaller... if you did not run the installer then remnants of fglrx could still be messing up your install. On the other hand, if you installed the proprietary driver using the fglrx-driver package, do aptitude purge fglrx-driver.
  • Make sure you are booting the Wheezy kernel and not the old Squeeze kernel. The Wheezy kernel may be lower priority in the GRUB boot list, but you need to boot the Wheezy kernel to use the Wheezy graphics stack, so just check your GRUB menu boot order and boot the "newest" kernel version you have available.
share|improve this answer
Those lines are there: fbdev-blacklist.conf:blacklist radeonfb fglrx-driver.conf:blacklist radeon What can be done about that? I don't suppose simply removing them help? How do I run the fglrx unintsaller? Reinstalled and uninstalled the other said packages. Didn't help. Kernel is 3.0 itself. Not using the old one. – fayaz Aug 24 '12 at 2:36
As long as blacklist radeon is in fglrx-driver.conf, you aren't going to get working X with the open source graphics drivers. It's now fully obvious to me that you did not remove fglrx the correct way, and that pieces of it are strewn throughout the system. I don't know how you installed it, though. If you installed it through a download on AMD's website, you need to run that same download file and pass the correct command line to uninstall. If you installed a Debian package, uninstall (and purge) that package. Also, kernel 3.0 is from Squeeze; Wheezy uses 3.2. – allquixotic Aug 24 '12 at 12:09
The next thing you'll probably complain about is that running ./ --uninstall complains that some of its files are missing. The --help option is useful. It says you can pass --force to uninstall anyway. If that doesn't work, you may have to dig deeper and try other commands... again, self-discovery via --help is the best way. – allquixotic Aug 24 '12 at 12:15
I had installed the proprietary drivers by referring this: . So purging the fglrx-driver worked. Everything is working now (although purging fglrx-glx failed). – fayaz Aug 25 '12 at 5:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.