Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a problem with a USB-to-RS485 adapter on Windows XP. This laptop is running a data logging program, and the adapter is connected to a temperature chamber. After a couple of hours of running, the adapter stops working. My guess is that Windows is "shutting down" the USB port where the adapter is connected. This is only a theory. I hoping someone can provide more information on how Windows powers down USB ports/hubs.

According to the Windows Device Manager, USB Root Hubs have an option labeled "Allow the computer to turn off this device to save power." The built-in Help (the question mark at the top-right of the window) says the following about this option.

Specifies whether the operation system turns off the selected device if that device is able to be turned off. If the device is busy doing something, however, (servicing a call, for example), the operating system will not shut down the device. The operating system will try to shut down every possible device only when it is hibernating. Some devices must stay on at all times. If you need the device to stay on at all times, do not check this box.

This is an ambiguous statement. It says it will not shut down the device if it is doing something. This implies if it is not doing something then it may shut it down, but the next sentence says it will only shut down the device when it is hibernating. So which is it?

share|improve this question

"Allow the computer to turn off this device to save power."

This option will do exactly what is says. It will turn it off when the device is not being used. For example, your adapter works for one hour maybe it was a peak time for data logging. But after that one hour of peak activity no activity was logged or monitored for around 1 - 3 hour, then windows would put it in sleep. So you should not select that option.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .