Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I ran scandisk on my external USB drive due to the inability to delete a few files. Windows asked me if I wanted to unmount the drive before the scan, warning me that it would be unusable until the scan was finished, and I said yes.

During the scan, my machine locked up, and I was forced to reboot the machine. When it came up, I was unable to access the drive, getting an error that "L:is not accessible, access is denied". Comupter Management sees the drive, and has the proper amount of disk space filled.

I booted into safe mode, and can access the drive with no problems, and I noticed that in explorer, all the folders have locks on them.

I booted back into windows, but still could not access the drive, getting the same error as above. Hovever, if I right click on the drive, select properties, and go to Customize, in the folder pictures ares, I select Choose File, and a window open up, that shows the root of the directory, with all the folder able to be accessed, but again, the icon is the folder icon with a lock on it. I can even copy files from the drive to another.

So, the files are not gone, windows can obviously access the drive no matter what it thinks, so there has to be a problem with the flag windows put on the drive when it ran the original scan that failed. I was able to run a scan both in safe mode with no problems, and in windows. In windows, I received the cannot access error the first time I run scan disk on it, but if I try again, it works fine.

Any ideas on how to clear the flag that windows set, so I can access the drive normally again?

share|improve this question
up vote 2 down vote accepted

Check Security.

I believe (but not certain) that the padlock icon on folders refers to NTFS permissions.

Right click the folder and click "Security". Make sure your name is there and that there are ticks in the allow column and that no user has ticks in the deny column.

share|improve this answer
That was it. I had checked permissions, but hadn't noticed that my user name was no longer in the list. Not sure how that happened, but after re-taking ownership of all the folders and sub directories, everything was back to normal. – Matt Thompson Sep 25 '09 at 1:39
Glad to hear and happy to help! – William Hilsum Sep 25 '09 at 1:53
Still can't change the folder icon to the default. While I have everything checked under allow, have ownership of all the folders, I still get the padlock icon. – Matt Thompson Sep 25 '09 at 3:19
Go to Command prompt and browse the directory, see if there are any thumbs.db and other special files (system / hidden). I have seen special files that can only be seen in command prompt before. If this does not work, simply try unplugging and restarting the usb disk, if nothing still, try resetting your computer as the permissions / icon are probably cached. – William Hilsum Sep 25 '09 at 3:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.