Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I won't try to get this all documented in this first post, as I am sure you folks will have a ton of questions for me.

I am having problems with my home LAN. For several weeks I have been having problem downloading large files. I shall define large files as over 400 MB for this discussion.

Internally I (it appears) can copy files back and forth from computer to computer using just about any operating system and application without problem.

When I attempt to download large files, like ISOs from mirrors, I consistently get corrupted files. I believe they are corrupted because the SHA1 hashes are incorrect.

If I grab the same file via a Amazon EC2 instance, the SHA1 hash is just fine.

At home my speed tests, and more importantly, packet loss tests, indicate that everything should be working just fine.

I don't know how to track down the problem at this point. That is why I have come here, hoping you all can teach me how to troubleshoot this issue.

If successful, I will writeup the process for others to follow.

What ideas do you folks have for me to try?

share|improve this question

1 Answer 1

When considering data corruption I would suspect packet fragmentation. This is hard to troubleshoot except to try setting the MTU on the affected router (e.g. your internet router) to lower values, and try again.

I would start by finding a consistently problematic site, and use that as your test. Then remove all intermediate routers and connect your computer/laptop directly to the source of your internet, and see if that solves it.

This might help: http://www.tolaris.com/2010/04/08/troubleshooting-path-mtu-problems/

share|improve this answer
    
What I meant about EC2 is that I SSH into an instance running on EC2 and I download the file from the mirror site to the EC2 box and run sha1sum on the file. All of this takes place on EC2. This confirms that the file from the mirror is not corrupt and that it can be downloaded without error. IOW, this is my control. It shows what right looks like. Example: I find centos 6.3 iso on a mirror site. I download it from the same mirror to my local computer and to the EC2 instance. I run sha1sum on my computer and the SHA1 doesn't match. I run sha1sum on the EC2 box and the file is good. –  tinjaw Aug 23 '12 at 22:18
    
OK, I understand now. I assume you don't have problems with every day browsing. It could still be TCP/IP packet fragmentation. I have also seen a bad/corrupt ethernet controller (e.g. perhaps on your internet router) that resulted in inconsistent data as you describe. –  Scott Presnell Aug 23 '12 at 22:31
    
Correct. Day to day browsing and email is just fine. The only real problem I had was a huge delay in facebook.com browsing. Sometimes it would fail out without loading. But, for the most part. That has fixed itself. [Gonna enjoy the evening and check back here tomorrow morning.] mturoute is a useful tool to have in my kit bag. –  tinjaw Aug 24 '12 at 0:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.