Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running an instance of Fedora 16 under VirtualBox (on a Win 7 Pro machine) as a development web server. It's suddenly gone invisible. I have it set to an IP address of 192.168.1.80; I can't ping that address, nor can I find the web pages on it.

I've confirmed that the correct page shows up when I enter "localhost" in a browser running under that virtual machine, and service httpd status seems to be indicating the httpd server is running properly. What would people recommend I do to investigate/fix this problem?

share|improve this question
1  
Does the guest (Fedora) show network connectivity? Can you ping the host (Windows) from the guest? Could there have been a change to the firewall settings in the guest? On the guest, what is the output of 'iptables -L'? Is the VirtualBox virtual adapter enabled? In VirtualBox, what type of network connection is configured for the guest? –  bgvaughan Aug 28 '12 at 11:43
    
@bgvaughan: Got it! Your questions got me on the right track. The problem was my new router. I just moved, and my new router was configured to hand out IP addresses in the 10.0.0.* range, NOT the 192.168.1.* range like the previous one. Changing the DHCP settings got it working again. Your questions DID get me pointed in the right direction, and you are the only one who responded, so if you want to put up an answer, the bounty's yours. –  BlairHippo Aug 28 '12 at 16:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.