Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a BSNL WLL hi-speed internet connection. My Windows XP machine is configured to use 10.24.24.2 as the IP address and 10.24.24.1 as the default gateway.

Everything was ok till I bought a new Linksys router and plugged it in as an AP. After I configured the new router to ip 10.24.24.2 and enable DHCP, my laptop joined to the new wireless network but without internet connection. I called the support team and he told me the modem is configured and locked to 10.24.24.1 and restricted to only one IP address 10.24.24.2. I don’t know why. How could I share my internet connection through the Linksys router?

share|improve this question
    
HOW did you configure the Linksys router? provide more info please. WAN should be static IP 10.24.24.2 and gateway 10.24.24.1 (any DNS settings?). LAN DHCP should be enabled and your clients should acquire their TCP/IP settings automatically vie DHCP. usually 192.168.1.xxx –  Molly7244 Sep 25 '09 at 1:46
    
please add router model & version to the question. –  quack quixote Oct 4 '09 at 21:42

3 Answers 3

It sounds like the tech guy was telling you the modem has locked onto your computer's MAC and will only give an IP address to that MAC. In the router's configuration utility you should be able to find a "clone MAC" option. You may be able to just enable it and have it automatically work; if not, you'll need to run

C:> getmac

and enter the output of that program into the MAC field of the router's configuration. This allows the router to look like your PC when you connect it to your modem.

If "getmac" doesn't work, try this command (look for "MAC" or "Hardware Address").

C:> ipconfig /all

You should be able to find more specific directions at Linksys' website. Or, if you post your router model here, we can give you more information.

share|improve this answer

Sounds like the modem isn't bridged at all.

If you have the modem plugged directly into the Access Point, ensure the AP doesn't try to obtain an EXTERNAL IP address. You will have to ensure the Internet Connection settings on the Linksys have 10.24.24.2 as the IP address and 10.24.24.1 as the gateway.

However the LAN IP setup of the Linksys should be something like 192.168.0.1. Your PC should then obtain and IP address/gateway from the Linksys router via DHCP (probably 192.168.0.2 as IP and 192.168.0.1 as gateway).

share|improve this answer

I would disable the DHCP on the router, and enable DHCP on the Linksys. Set all your clients to DHCP (not static) and have them connect to the wireless network.

That way, the Linksys will give an IP address, rather than the modem, and you can get around their silly 1 address limit. Unless the manufacturer has artificially limited the number of connections to 1, and in that case you should demand a refund and purchase a better modem.

In most LAN networks, it doesn't normally matter which device assigns the IP address to clients, so long that it does assign the correct IP, subnet mask and gateway.

There'll be a section to configure the DHCP of the Linksys, and just simply change the default gateway to the IP address of your modem - in this case, 10.24.24.1.

share|improve this answer
    
@EvilChookie did you get your caffeine today? reread the question please. his linksys is his router. he may not own the modem, and the ISP told him only 1 computer allowed. (and go get some caffeine!) –  quack quixote Oct 4 '09 at 18:11
    
@~quack: I have seen several ISP's that provide 'basic' modems to clients, where they say that only one computer is allowed - when it's just a silly limitation on the DHCP server on the modem. If that's the case, then an alternate DHCP server (like using the linksys) should solve the problem. More information - and feedback on my suggestion - is required from the OP. And I don't really understand the point about caffiene. –  EvilChookie Oct 5 '09 at 2:54
    
@EvilChookie think i had too much yesterday (caffeine). your answer starts "disable DHCP on the router, enable DHCP on the Linksys". think you mean "disable DHCP on the modem"? just trying to clarify. –  quack quixote Oct 5 '09 at 21:32
    
@~quack: A router is the device that performs authentication and NAT routing in a network. Sometimes, routers will have a modem built in. Those devices are called gateways, modem routers, or just routers. Netgear's DG834 is a fine example. In this case, the OP has what sounds like a modem-router device. I have just fallen into the habit of calling them routers (since modem confused a lot of the non-technical folk I used to work with. "What, we don't have a modem, we have broadband!"). For lack of a better explanation, disable all DHCP servers except the Linksys, and the problem should vanish. –  EvilChookie Oct 5 '09 at 22:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.