Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using Putty I am able to login successfully using root user id but not with other user ids. These user ids are just normal users that belong to a developer group.

Originally, I used 0.61 version. After reading other threads on this site, I upgraded to 0.62, but the problem continues. I use CentOS 5 server.

You may have the urge to comment that I would have entered bad password, but trust me I have tried the login after changing the password several times, as I have no problem to login as root through the same putty window.

Below is the event log from the putty window. Any help is appreciated.

2012-08-24 02:20:01 Connecting to 999.99.99.999 port 22
2012-08-24 02:20:07 Server version: SSH-2.0-OpenSSH_4.3
2012-08-24 02:20:07 Using SSH protocol version 2
2012-08-24 02:20:07 We claim version: SSH-2.0-PuTTY_Release_0.62
2012-08-24 02:20:07 Doing Diffie-Hellman group exchange
2012-08-24 02:20:08 Doing Diffie-Hellman key exchange with hash SHA-1
2012-08-24 02:20:08 Host key fingerprint is:
2012-08-24 02:20:08 ssh-rsa 2048 fa:41:23:0f:62:9a:41:ea:81:11:8a:81:86:ba:fc:b3
2012-08-24 02:20:08 Initialised AES-256 SDCTR client->server encryption
2012-08-24 02:20:08 Initialised HMAC-SHA1 client->server MAC algorithm
2012-08-24 02:20:08 Initialised AES-256 SDCTR server->client encryption
2012-08-24 02:20:08 Initialised HMAC-SHA1 server->client MAC algorithm
2012-08-24 02:20:13 Using SSPI from SECUR32.DLL
2012-08-24 02:20:13 Attempting GSSAPI authentication
2012-08-24 02:20:13 GSSAPI authentication request refused
2012-08-24 02:20:16 Sent password
2012-08-24 02:20:19 Password authentication failed
share|improve this question

closed as off-topic by Dave, Kevin Panko, Raystafarian, Nifle, harrymc May 15 '14 at 18:32

  • This question does not appear to be about computer software or computer hardware within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

Can you log into your CentOS 5 server with other user ids using SSH from your CentoOS 5 box? May be your server uses the AllowUser construct to pick specific users who can log in? – jpe Aug 24 '12 at 6:49
Thank you all!. I was REALLY amazed to see so many instantaneous responses. It really makes a HUGE difference when you are frustrated with a problem. Community help is great!. I shall do the same with whatever little knowledge I possess. – infotoknowledge Aug 24 '12 at 7:03
This question appears to be off-topic because it is answered by the OP in a comment of another post. – Dave May 11 '14 at 9:59

check this link

here same problem solved.

so try.

share|improve this answer
Thank you all the responders!. My problem was solved like this. I had created the normal users with useradd command and supplied the password with the -p option. This password didn't work for some reason. I recreated the user few times with no success. However, this time I reset the password for the user using the passwd command and voila!, it worked. I did the same thing with other users and all of them worked. For some reason the password supplied with the useradd command is not working. Well, I am not going to research into it, since I have a workaround!...phew!..Thanks again! – infotoknowledge Aug 24 '12 at 7:28
@Sandy8086 perhaps you add to your answer a line about checking if the password for the user works from the local machine. The link you provided is definitely relevant, but the problem was not the same that the OP had. – jpe Aug 24 '12 at 8:24
As explained above, I think my problem was not solved by any of the suggestions / solutions in the responses, but with my own additional attempts. Anyway, for the kind of quick responses I got, I am ready to vote up the site. – infotoknowledge Aug 24 '12 at 8:32

Check this link:

It helped me solve the problem.

share|improve this answer
Links to external resources are encouraged, but please add context around the link so your fellow users will have some idea what it is and why it’s there. Always quote the most relevant part of an important link, in case the target site is unreachable or goes permanently offline – Tog Jun 19 '13 at 21:34

Its just the "-p, --password" command after useradd or usermod

just create a user without any details and use after

passwd USERID

than it works

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .