Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

ctrl + D closes an iterm2 window. Where's this option to disable it? I can't find it in preferences->keys or preferences->general.

share|improve this question
    
Control-D is EOF (End of file). Searching for shell closure on end of term might help. (Not sure since I have no OS/X to test it with). –  Hennes Aug 24 '12 at 12:22
    
@Hennes I didn't know that. I've set a zsh option (ignoreeof) so the shell won't close for me when I accidentally hit it. Thanks for the tip! –  simont Aug 24 '12 at 12:42
    
Let me move it to an answer so we can close this question. :) –  Hennes Aug 24 '12 at 15:24

1 Answer 1

up vote 0 down vote accepted

Control-D is EOF (End of file). Sending end of file to a shell session usually closes the shell.

You can set IGNOREEOF to force the user to type exit or logout instead of just pressing ^D.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.