Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My DVD-Rom recently broke and I have installed Ubuntu from my USB stick with no problem. But now when I enter BIOS, there is no Option for USB. I hit F8 and it's not listed there either. I know my BIOS supports booting from USB because I used it before but I don't know what happened to it now. Please help, thanks.

share|improve this question
    
Did you check if USB device support during boot is enabled in the BIOS? This might be disabled by default. Do you have a USB keyboard or PS2 keyboard? –  mnmnc Aug 24 '12 at 14:52
    
I have a PS2 keyboard. I checked bios and I couldn't find an option like that. I have an ASUS P5KPL-CM –  Mertcan Ekiz Aug 24 '12 at 14:54
    
Yeah. I guess so. You have a PS2 keyboard which means you did not need USB support during boot time up until now. In the BIOS there should be an option for this. Im pretty sure it will be but you need to search for it. –  mnmnc Aug 24 '12 at 14:56
add comment

1 Answer

Please review this article with the guide how to enable USB support in the boot time.

I think you have it disabled since you are using PS2 keyboard. Its under Integrated Peripherals section in the BIOS.

share|improve this answer
    
In every BIOS? –  Daniel Beck Aug 24 '12 at 15:00
    
@DanielBeck Of course not. But i will wait for OP to get back if i'm mistaken :) –  mnmnc Aug 24 '12 at 15:04
    
My bios is not like that and I have a lot less options. I tried updating the BIOS and still had not more options added. Also my ethernet didn't work after that. I flashed the old rom again and I got one extra option at "Boot" section. It was named hard disk drives and when I entered it had 2 options, HDD and USB Mass Storage. 1st one was set to USB and I changed it to HDD. When I pressed F8 at start up the USB boot option was there again. Don't really know what caused it and how it got solved but it's working now. –  Mertcan Ekiz Aug 24 '12 at 15:35
    
Well. I'm glad it's working although flashing BIOS or old ROM whatever you mean by that seems a bit radical form me. Pity you did not specified any hardware details about your computer - we might have helped better. –  mnmnc Aug 24 '12 at 15:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.