Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hey I want to setup a reverse sshfs tunnel. I have a home server which sits behind some type of NAT which makes it impossible for a remote computer to sshfs the home file system. On the local computer I run the following command to establish a reverse ssh tunnel:

ssh -R 14443:localhost:22 remoteUser@remoteComp

From the remote computer I can successfully ssh to the home server:

ssh localUser@localhost -p 14443

However I can not mount home file system:

sshfs -p 14443 localUser@localhost:/home/localUser RemoteFolder/

as I receive the following error:

fuse: failed to open /dev/fuse: Permission denied

Ofcourse the remoteUser has been added to the group fuse. Any help appreciated :)

share|improve this question

The problem was with the remote server I'm using. Fuse was not functioning on the Virtual Private Server(VPS), and the issue was resolved by the VPS admin. The admin had to 'enable fuse'.

This maybe an issue for VPS hosted with openvz.

share|improve this answer
    
Yeah this is why KVM is so much nicer to work with. You can enable kernel modules as needed. – Navin Sep 18 '15 at 1:35

Could check on your remote system what the permission of /dev/fuse is? ls -l /dev/fuse. It means that your user/group is not able to write to /dev/fuse on your remote system.

share|improve this answer
    
Heres the result crw-rw---- 1 root fuse 10, 229 May 8 17:32 /dev/fuse Do I need to change something? Thanks :). – Kurent Aug 24 '12 at 15:56
    
So it is owned by group fuse. What does 'groups remoteUser' return? If you do not see fuse, then either you did not add it to the fuse group or need to log out and log in again. – johnshen64 Aug 24 '12 at 16:34
    
In this case remoteUser = root. groups root returns root : root fuse. This is after logout & login, and sshfs is still returning the same error. – Kurent Aug 25 '12 at 7:01
    
Thanks for help. – Kurent Aug 25 '12 at 9:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.