Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a RHEL5.5 server, and the system engineering guys at my company said that they have recently installed Intel C++ 11.1 compiler on the box.

But, when I do a cc -v, I get

Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --with-cpu=generic --host=x86_64-redhat-linux
Thread model: posix
gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)

I did a which cc, and it points to /usr/bin where cc is a soft link to gcc. People at the system engineering aren't too clear about the path where they have installed it either.

There is nothing that says if this is the Intel compiler or the default gcc compiler.

So, is there a command that lists the compiler name?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

The Intel C++ compiler is usually installed in /opt/intel. There's a script you have to run to set up your environment to use it, usually iccvars.sh.

For the most common installation options, this should work:

. /opt/intel/bin/iccvars.sh intel64
icc -v
share|improve this answer
    
maybe a silly question but does 64 indicate 64 bit? can I use intel32? –  roymustang86 Aug 24 '12 at 18:00
    
I used the option ia32 –  roymustang86 Aug 24 '12 at 18:58
    
Yes, on a 64-bit installation, you can specify either 32-bit or 64-bit targets. –  David Schwartz Aug 24 '12 at 20:26
add comment

There is nothing that says if this is the Intel compiler or the default gcc compiler.

You quoted

gcc version 4.1.2

Which suggests to me it is gcc not Intel

aren't too clear about the path where they have installed it

Try locate cc

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.