Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As the subject states, I can't turn on my dell xps 1330 without the power lead in. There is nothing from pressing the button.

It has a newish fully charged battery and have tried a couple of good ones.

Once I put the power lead in I can turn it on and I can remove the power lead and everything's fine?

Any ideas?

UPDATE

I've also noticed a flashing red battery icon on the front of the laptop when any of the 2 decent batteries are in there! Sounds like a shot charging component / motherboard?

share|improve this question
    
Have you tried removing the battery (while it is not plugged in) and putting it back in? –  terdon Aug 25 '12 at 13:22
    
Yes tried that and pressed power whilst battery is out.. –  digiout Aug 26 '12 at 9:32
    
Update added above –  digiout Aug 26 '12 at 9:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.