Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have problems in creating an account on my Nokia Lumia 800 (OS version: 7.10.8773.98, of course with Windows Phone 7.1 mounted with all updates) to one of my company's Microsoft Exchange 2010 server, because it cannot provide a trusted certificate...but only when contacting it from outside my network (like https ://mail.(CompanyName).com).

Accessing the server from inside my network (pointing directly to the machine name or internal IP address: https ://(MachineName) or https ://10.0.1.200) gives me NO PROBLEM AT ALL!

Setting correctly (I guess) all the parameters for the account (accessing from outside my network), the connection (after correctly set my credentials as asked) will not be established.

It gives the next error (translated from my language manually):

Error of <CompanyName>
  There is a problem with the certificate of (Server Address). Please contact support or the provider.

  Last try: X minutes ago
  Error code: 80072F06

I've tried all possible configurations and parameters (including the check The server requires an encrypted (SSL) connection, of course), but no way.

EDITED: As suggested by Oliver Salzburg, I also tried this way without any results. I tried so:

  1. I went to my OWA (Outlook Web Access) that gives me the same problem (problems the certificate, it's not trusted)
  2. After accepting to continue, I clicked on the Error in Certificate button of the Internet Explorer 9 address bar -> Show Certificates -> page Details, show: -> Copy to file... button -> in the exporting wizard: Next -> Binary encoding DER X.509 (.cer) (but there was also Base binary 64 X.509 (.cer), no way) -> Next -> saved to a new file
  3. From my Google Mail Account, I sent a mail to myself the certificate as attachment
  4. I read the mail from my WP7 phone, saved the attachment and then ran it: answering Yes to Do you wany to install the certificate? of course...
  5. Closed any active program and rebooted the phone
  6. Re-tried in synchronizing my account....:(...SAME PROBLEM!

EDITED 2: Thanks again to Oliver Salzburg, I tried the next solution:

  1. I went to the site https://www.testexchangeconnectivity.com/
  2. I selected Exchange ActiveSync option, as suggested
  3. I setted all my parameters, as I made for my phone
  4. I also setted the option Ignore SSL attendibility (and in another test I didn't)
  5. I performed my test

This is the complete log (I removed my parameters):

Log of the Exchange ActiveSync test

Seems the same problem (machine name in the certificate is different from the external Exchange website domain name?)!

It is possible to get rid of this annoying (I know by myself who is this server!) problem?

Thank you very much.

share|improve this question

closed as off-topic by Shekhar, Keltari, Tog, Mokubai, Scott Aug 17 '13 at 0:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is not about computer hardware or software, within the scope defined in the help center." – Shekhar, Keltari, Tog, Mokubai, Scott
If this question can be reworded to fit the rules in the help center, please edit the question.

    
A quick search turned up this: johnliu.net/blog/2010/10/27/… –  Oliver Salzburg Aug 25 '12 at 15:27
    
I've tried your solution and edited my question, because it's still not working for me! –  MAXE Aug 25 '12 at 15:51
1  
Can you get a better error description by using the ActiveSync test on testexchangeconnectivity.com? –  Oliver Salzburg Aug 25 '12 at 16:25