Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I cannot for the life of me get Redmine to run. I'm not a Ruby programmer. I tried using apt-get, but the installer was failing so I opted to do it by hand from Redmine's source. When I try launching it in my browser, I get:

Application error
Rails application failed to start properly

Here's the log file:

[notice] FastCGI: process manager initialized (pid 11163)
[notice] Apache/2.2.22 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 Phusion_Passenger/2.2.1$
[warn] FastCGI: (dynamic) server "/project/redmine/public/dispatch.fcgi" started (pid 11185)
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require': no such file to load -- fcgi (LoadE$    
    from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'    
    from /project/redmine/public/dispatch.fcgi:4

First, here's my versions:

$ ruby -v; rails -v; gem -v
ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]
Rails 3.2.6
1.8.15

$ uname -a
Linux host 3.2.0-29-generic-pae #46-Ubuntu SMP Fri Jul 27 17:25:43 UTC 2012 i686 i686 i386 GNU/Linux

According to Redmine's documentation, that should work just fine.

I have redmine located at /project/redmine. All files in that path have 755 permissions except the log folder, which is 666. I'm using the following apache configuration:

Alias /redmine "/project/redmine/public/"
<Directory "/project/redmine/public/">
    Options Indexes ExecCGI FollowSymLinks
    RailsBaseURI /project/redmine
    PassengerResolveSymlinksInDocumentRoot on
    Order allow,deny
    Allow from all
    AllowOverride all
</Directory>

Apache is sporting the following modules:

core mod_log_config mod_logio prefork http_core mod_so mod_actions mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env mod_fastcgi mod_mime mod_negotiation mod_passenger mod_php5 mod_reqtimeout mod_rewrite mod_setenvif mod_status

This is what my dispatch.fcgi. It's the default, but the first two require lines were added by me trying to fix this. It looks like:

#!/usr/bin/ruby

require 'rubygems'
require 'fcgi'
require File.dirname(__FILE__) + '/../config/boot'
require File.dirname(__FILE__) + '/../config/environment'

class Rack::PathInfoRewriter
  def initialize(app)
    @app = app
  end

  def call(env)
    env.delete('SCRIPT_NAME')
    parts = env['REQUEST_URI'].split('?')
    env['PATH_INFO'] = parts[0]
    env['QUERY_STRING'] = parts[1].to_s
    @app.call(env)
  end
end

Rack::Handler::FastCGI.run Rack::PathInfoRewriter.new(RedmineApp::Application)

What am I missing?

share|improve this question
    
Have you installed the fcgi gem? sudo gem install fcgi –  Oliver Salzburg Aug 25 '12 at 19:14
    
I hadn't. Installing it gets me past the hurdle I was facing. Submit that as an answer and I'll accept it. –  Amy Aug 25 '12 at 21:18
add comment

2 Answers

up vote 2 down vote accepted

From the part `gem_original_require': no such file to load -- fcgi of the error message, I assume you're missing the fcgi gem.

Install it with:

sudo gem install fcgi
share|improve this answer
add comment

Try Bitnami's Redmine stack instead. It's an out-of-the-box package. After the installation Redmine is (and every other stack on Bitnami) ready to use. You just need to make the necessary project, tracker, user etc. definitions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.