Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Studio XPS 9100 running 64 bit Windows 7.

Yesterday, after a reboot, networking completely stopped working. The computer in question was connected by ethernet to a Linksys Wired/Wireless router which is attached to my cable modem.

The computer can obtain an IP address from DHCP, but it is unable to connect to the internet. Running Windows diagnostics suggests that I should power off the router, which I have attempted with no success.

Other relevant things that I have tried:

  1. List item
  2. I can ping the loopback address and the address that I get from DHCP. I cannot ping the gateway (the IP address of the router).
  3. I have plugged another computer into the same ethernet cable, so it is not a cable problem.
  4. I have tried other ports on the router.
  5. All other machines/internet devices going through this router work fine.
  6. I have attempted to clear/reset the TCP stack with "netsh int ip reset reset.log" as well as resetting winsock with netsh.
  7. I attached a USB wifi card to the computer. The wifi card was detected, installed with current drivers, claimed that it was working correctly, but could not see any networks. Other devices in my home can see roughly 5 networks (mine plus neighbors).
  8. Rebooting in safe mode with networking will allow the computer to connect to the internet.
  9. I'm currently rebooted into a minimal configuration using msconfig.

Is there anything else I can try, other than turning on every service and application on one at a time and rebooting to try to figure out what's clobbering my network?

share|improve this question
    
What happens when you assign static IP and DNS of 8.8.8.8 ? –  Darius Aug 25 '12 at 20:55
    
No luck. Assigned static IP with DNS of 8.8.8.8 and had the same problem when I rebooted with everything on. –  Paul Smith Aug 25 '12 at 21:41
    
You don't mention scanning for malware. The fact that it can reach the internet in safemode hints at an infection to me. –  Deirdre Aug 25 '12 at 21:42
    
Ran a full updated virus scan 2 days ago, and just ran MalwareBytes. No sign of infection. –  Paul Smith Aug 25 '12 at 23:01
    
Reset Winsock, especially the LSP catalog. –  ta.speot.is Aug 26 '12 at 5:33
show 1 more comment

2 Answers

up vote 0 down vote accepted

If you have mcafee or Norton Internet security try uninstalling and see if connectivity is restored

Disabling in my experience did not work. Required full uninstall.

Then run any windows updates then reinstall.

share|improve this answer
    
Completely uninstalling McAfee resolved my network problems. I wish I had a better understanding of why this was the issue, but I'll have to settle for having a functional computer again. Thanks very much for everyone's suggestions. –  Paul Smith Aug 27 '12 at 17:00
add comment
  • Check and make sure you dont have a firewall running rampant on the PC.
  • System restore may work at fixing the issue.
  • Try another program like spybotSD (free) to make sure it wasnt missed by the others.
  • Run the Windows Network Troubleshooting wizard.
  • Manually start enabling services/apps at boot.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.