Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How do I disable administrator prompt in Windows 8?

I always used Windows 7 Ultimate x64 (SP1) with User Account Control completely turned off - the slider in the settings window was set to the bottom most value. I was then able to copy files into programs / system folders without any additional confirmation ("You need the rights to copy into this folder..." --> "Continue") and all my programs were able to start with no problems.

Now I use Windows 8 Pro x64 (RTM), and I set the slider to the same value again. However, I still need to confirm copying or changing files in programs / system folders, which is pretty nasty. But worst is that some programs can't start anymore. For example, one program always complains about not being able to write into the temporary directory, the command prompt can't create a link in my user profile folder with mklink, another program can't hook the needed system routines to enable window snapping.

If I run all these programs explicitly with administrative rights, they work as expected and like in Windows 7. For me it looks like UAC doesn't beg me anymore with dark-screen confirmations, but I still do not automatically get elevated rights when starting programs.

I found one way to fix this, but for only one shortcut at a time: Right click the shortcut, click the "Advanced" button and check "Run as administrator". However, I want this to be done automatically.

Do I have to configure additional settings in Windows 8 to make it behave like in Windows 7 (user account settings, group policies...)?

share|improve this question
add comment

marked as duplicate by Indrek, Moab, Nifle, Canadian Luke, techie007 Aug 26 '12 at 17:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Start Menu--Control Panel--User Account. You can modify the privilege and name here. If you can not modify the privilege, ttry to reboot the computer and enter the Safe Mode, choose Administrator and click Yes. And then do the first method again. At last, reboot is needed.

OR

1)Reboot your computer into safe mode with command prompt 2)Type “net localgroup Administrators username /add” and hit enter 3)Reboot computer into Windows normally 4)Logon and you’ll have admin privileges.

OR

EDIT: TRY THIS: You can re-enable it by following the steps below, but it would be best to create a new administrator account (not the built in Administrator account) instead. The first set of steps below will take you through enabling the built in Administrator account. The second set of steps will take you through creating a new user account and changing that account to an administrator.

Here is how you can re-enable the built in Administrator account: Enter the Start screen Press Windows key + C on your keyboard to show the Charms bar (If you have a touchscreen: Touch the right edge of the screen and swipe your finger to the center of the screen to show the Charms bar) Click Search Type Computer Click Computer Right click Computer in the left column Click Manage Click Local Users and Groups in the left column of the Computer Management window Open Users Right click Administrator Click Properties Uncheck the Account is disabled box Click OK

Here are steps to help you to create a new administrator account that isn't the built in Administrator account: Enter the Start screen Press Windows key + C on your keyboard to show the Charms bar (If you have a touchscreen: Touch the right edge of the screen and swipe your finger to the center of the screen to show the Charms bar) Click Settings Click More PC settings Click Users in the left column Click Add a user

On this screen you will need to either enter a Microsoft account that you want to use for the new account or you'll need to click the Don't want this user to sign in with a Microsoft account? link to be able to create a local account. Once the account is created, follow these steps to change the new account to an administrator account: Enter the Start screen Press Windows key + C on your keyboard to show the Charms bar (If you have a touchscreen: Touch the right edge of the screen and swipe your finger to the center of the screen to show the Charms bar) Click Search Type User Accounts Click Settings in the right column Click User Accounts Click Manage another account Click the new user account Click Change the account type Select Administrator Click Change Account Type

Then you should be able to log into the new account with administrator abilities.

share|improve this answer
    
I have already modified the User Account Setting to the lowest mode (e.g. "off") and rebooted my PC, that's the current status. My user is also in the administrators group already as the administrative tools have shown me. –  PacMani Aug 25 '12 at 22:35
    
Updated. Try this. –  Andrew Aug 25 '12 at 22:40
    
Just to pick it out, I have tried creating another account with administrator rights. But it ended up in the same problem: I have the administrative rights, but I never get elevated rights. E.g., I am actually able to explicitly run programs as administrator (with right click > Run as administrator), but I want this to happen implicitly and automatically for all my programs, like in Win7. –  PacMani Aug 25 '12 at 22:47
    
Bizzare. Thats one of the nice things about Windows, is that is ALMOST always make you and Admin, and that is the end of it. Weird. Let me keep digging in my sandbox. –  Andrew Aug 25 '12 at 22:50
    
I did some more digging, and this is what I found: In Windows 8, you cannot disable UAC, as it is necessary for several things, including Immersive/Modern Apps (in addition to the same things it's always been needed for like IE Low-Privilege Mode, sandboxing, etc., etc.). You should never run things as the built-in Administrator account (or any account with equivalent properties). Many things will be broken and this isn't a supported usage scenario. –  Andrew Aug 26 '12 at 20:56
show 4 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.