Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a computer that is connected to the internet via wifi. I then have a ethernet cable coming out from my wifi computer into another computer which has no wifi or place to plug into ethernet.

I have shared the wifi connection to the LAN port, and the computer successfully gets internet. But, on that computer I have a FTP server that I want the wifi network to be able to connect to. Since the computer is connected to the ethernet port, I can't access it from another computer on wifi.

Does anyone know how I could do this?

share|improve this question

migrated from serverfault.com Aug 26 '12 at 1:46

This question came from our site for professional system and network administrators.

    
This may not be possible. To know for sure you will need to tell us, among other things, what operating system you are running on the bridge computer... –  voretaq7 Aug 26 '12 at 1:46
    
Running Windows 7 64-bit on both computers. –  cheese5505 Aug 26 '12 at 1:48
    
I have a feeling that it is not possible. –  cheese5505 Aug 26 '12 at 2:43

3 Answers 3

I have shared the wifi connection to the LAN port

If you're using Internet Connection Sharing (ICS) your "wifi computer" will be (in general terms) acting as a router for your other computer. This means that requests that come in to your "wifi computer" are treated as being for that computer, not the other computer.

You can "forward" ports by clicking the Advanced (it's called Settings on my Windows 8 machine) button on the property page that allows you to enable ICS. You'll get some more options:

Service Forwarding

In your case, you'd most likely want to set the Name or IP address to the IP address of your other computer, and the external and internal port numbers to 21 (for FTP). There may already be a preconfigured FTP service option you can use, too (you'll still need to supply the IP address).

All that said, your other computer will still be behind a NAT. If you're more interested in having it behave like it's on the same network you might better turning off ICS and just bridging your wifi and fixed adapters.

enter image description here

share|improve this answer
    
Thanks, also, how would I do a range of ports? (Such as 55000 - 56000) –  cheese5505 Aug 26 '12 at 3:43
    
@cheese5505 Not sure about through the UI, you might be able to type the ranges (from1-from2 and to1-to2). If that doesn't work, the documentation for mapping ranges through a configuration file is available here. –  ta.speot.is Aug 26 '12 at 3:47
    
I was just there, I couldn't understand so I found another page. –  cheese5505 Aug 26 '12 at 3:49

Why not just get a USB WiFi dongle for the remote computer? It removes the bridge and any routing issues and puts both computers on the same network.

share|improve this answer
    
I am probably going to do that, but currently I can't. –  cheese5505 Aug 26 '12 at 3:21

You may want to check if your browser (or computer) is using a "Proxy" setting. If you can FTP with that kind of set up then I'd be willing to bet that you simply fudged up a proxy setting somewhere - likely in your browser. Otherwise, I would be tempted to go into explaining all about making "null" Ethernet cables.

Then again, you did say you have a Ethernet cable from your WiFi computer but nowhere to plug that cable in to on the other computer??? This is confusing since Ethernet and "NIC"s are often terms that are used interchangeably. NIC = Network Interface Card which is also known as (aka) an "Ethernet" port.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.