Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a Windows XP system with an AMD mainboard (GA-890GPA-UD3H) and we are using the onboard RAID capability. The system is configured in RAID 1 (using the tool AMD RAIDXpert). It consists of two 500GB Samsung HD502IJ hard drives.

The problem is that the array is failing often. The error message given is: Logical drive goes critical. Therefore, the drives are not mirrored any more.

I can rebuild the drives, but this does not help a lot. The error repeats irregularly/erratically. Sometimes it fails after 3 days, sometimes after 7 days, so it's not stable.

What's the problem and how do I prove it? I can get S.M.A.R.T information on the drives and they are fine individually.

share|improve this question

migrated from serverfault.com Aug 26 '12 at 4:17

This question came from our site for professional system and network administrators.

    
It's a GA-890GPA-UD3H mainboard. It has two RAID controllers. Both of them fail. –  vanCompute Aug 20 '12 at 11:57
    
SAMSUNG HD502IJ, those are the 2 hard drives –  vanCompute Aug 20 '12 at 12:22
    
Yesterday I saw it: The first drive disconnected and it reconnected within a second, but the RAID was broken. But y did the first drive disconnect? –  vanCompute Aug 26 '12 at 14:06

2 Answers 2

Had the same problem with consumer (WD and Hitachi) hard disks mounted in various NAS (with hardware RAID).

After many experiments, I found that my problem was related to different ways disks handle read delays and timeouts.

I had to enable TLER/CCTL on the drives firmware. Arrays worked flawlessly since then.

See also http://en.wikipedia.org/wiki/Error_recovery_control

share|improve this answer
    
Sounds interesting. May be the problem. Do you know a tool to enable CCTL? –  vanCompute Aug 20 '12 at 10:38
    
@vanCompute IIRC a tool called HDAT2 was used for Hitachi drives. Another person reconfigured Hitachi drivers, I worked only on WD ones, with the specific WDTLER utility. And keep in mind that unfortunately not every drive support altering the read timeout. It depends on model number and specific firmware revision. You'll have to try... –  Axeman Aug 20 '12 at 10:58

I've had plenty of problems with Samsung drives and an AMD chipset (in a HP Microserver). It's a 780G chipset I believe.

I use Linux, and with high throughput on the drives i'll get log messages complaining the controller didn't respond in time and was reset. Eventually it ended up corrupting the array. Turning off AHCI and dropping down to SATA1 helped a bit, but didn't completely clear the issue.

A friend with the same hardware had the same problem on Windows Home Server, though I don't remember what the logs said.

Can you see anything in eventvwr about the drives?

share|improve this answer
    
I can see an event by AMD RAID API: Logical drive "myraid" goes critical due to disk(s)port 1 target 1 failure.. –  vanCompute Aug 20 '12 at 9:58
    
On Linux do you use mdadm? (Not related to my question.) –  vanCompute Aug 20 '12 at 10:36
    
I do use mdadm, but it's not related to the problem - I got it when the array was broken up, too. The problem even persisted when I used freenas, so it doesn't look like a driver issue. I suspect there is a hardware issue with that chipset. –  seanyseansean Aug 20 '12 at 10:51
    
So, do you use a softraid, and it fails? Or a fake/host-raid? –  vanCompute Aug 20 '12 at 10:55
    
Fails with mdadm raid as well as with the array broken up (no raid). Seems to be provoked by heavy throughput but not always, I had a period when it happened at boot every time too. –  seanyseansean Aug 20 '12 at 10:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.