Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I like using my iTerm2 window in transparent mode, full screen so I can code and see my desktop picture as well.

I have upgraded to Lion and now when I enter full screen it gets rid of my desktop!

Is there any way to change this? Mission Control is fantastic, but this single thing is bothering me a lot. Thanks.

share|improve this question
2  
If you just want to see your desktop background, you can set iTerm2 to use a background image as well. – slhck Aug 26 '12 at 9:05

It took me a while to find this tonight, so I’ll respond here since this was near my top search results for how to disable Lion fullscreen mode in iTerm2, and this is probably what many people will be looking for.

  1. In iTerm2, open Preferences
  2. Select General
  3. Uncheck Lion-style fullscreen windows
share|improve this answer
1  
here, have as many upvotes as you like fine sir. – krichard Feb 12 '13 at 19:26

FYI, iTerm2 Version 3 (currently, 2.9.20160206 beta) lists this option as Native full screen windows, under the heading Window.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .