Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have three hard drives on my PC, two of which are bootable. One has my current Windows 7 installation and the other has an old broken Windows XP installation (missing hal.dll) that I'm not interested in fixing anymore. I plan to format it soon, but there's still a lot of data on it and that's why I haven't gotten around to doing that yet.

Now this is a new setup and everything worked out fine after installing Windows 7 on the main hard drive. It would always boot up on the Windows 7 drive, but something changed that I'm not aware of recently and now the boot priority is my old Windows XP disk. This is fine as long as I'm around to manually override boot-up, but I've set this machine to hibernate and also wake up at certain times and I'm usually not around when this happens. So I come home and find my PC has been stuck in the "missing hal.dll" screen for several hours.

I've already looked in my BIOS and there doesn't seem to be a way to change the boot priority. Here's pics of the BIOS that came with my ASUSTeK F1A75-M LE:

Main BIOS:

Main BIOS

Boot options:

Boot options

As you can see the only option in boot priorities is the wrong HDD. I need to change that to the one indicated. I've looked around online and in the manual but I can't find anything useful. Any help would be much appreciated.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Managed to set the hdd boot priorities. It was in Hard Drive BBS Priorities under Boot Override.

share|improve this answer
  • The boot priorities normally change with SHIFT + + and SHIFT + - , the keys directly adjacent to the backspace key.

  • Can't you access the Boot Override Menu just below the Boot Option Priorities and move the second hard drive to the first place?

  • If not, try taking your BIOS to Optimal Settings or Default Settings since you think something changed and this stopped working.

  • Last option would be to swap the wires from the inside between the 2 hard drives.

share|improve this answer
    
Sorry about taking so long to get back. I tried your suggestions and none of them worked. I can't change the priority order using any shortcut keys. Choosing an HDD in the boot override section is the same as pressing F8 during boot. It booted find when I disconnected the other two HDDs but reverted to the wrong one when i plugged them back in. And yes, I also tried switching their SATA ports inside. Optimal and Default settings didn't change anything at all. –  defurious Sep 1 '12 at 6:24
    
connect ONLY the hard drive you want to boot with to SATA port numbered 1 on the motherboard, power it on an boot. once that works connect the other drive and see what happens.. –  aliasgar Sep 1 '12 at 6:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.