Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to run eclipse-jee-juno-win32-x86_64 on Windows 7, but it raised the following error

java runtime environment JRE or java development kit must be available in order to run eclipse. No java virtual machine was found after searching in the following location ........

Baring in mind that i have both Java JRE 7 and Java jdk1.7.0_06 installed at C:\Program Files\Java.

The other strange thing also that Eclipse used to run without any problems yesterday, but today i have downloaded the JDK 1.7.0_06 and i set the JAVA_HOME to be C:\Program Files\Java\jdk1.7.0_06. So i don't know if the problem is related to this or not.

So what might be the problem in running Eclipse?

share|improve this question

2 Answers 2

Problem may be the PATH environment variable isn't pointing to where there is a java.exe Also when you set an environment variable to point to a directory it doesn't scan all subdirectories. So don't confuse installing java.exe to c:\program files\java and installing it to c:\program files\java\jdk1.7.0_06. And if it says it searched a location don't assume it searched all subdirectories of it.

share|improve this answer

One way that has always worked for me is to simply copy the JRE folder to the eclipse that you are running. Granted, it uses about 236 Mb of unnecessary disk space if you have it elsewhere.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.