Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Metasploit from Win 7 x64, and I've set up my Metasploitable 2 virtual machine on VMware Player. I can ping Metasploitable's IP address from the Metasploit console, however if I use nmap it says:

Note: Host seems down. If it is really up, but blocking our ping probles, try -Pn

I try it with the -Pn switch, it says

Nmap done: 1 IP address (0 hosts up) scanned in 0.64 seconds

I've disabled my Windows firewall and I'm running Metasploit as admin. Why can't I nmap my virtual machine?

share|improve this question

migrated from stackoverflow.com Aug 26 '12 at 14:50

This question came from our site for professional and enthusiast programmers.

    
Can you add the output (sanitized if you like) of nmap --iflist and nmap --route-dst $TARGET where $TARGET is the IP of the Metasploitable VM? –  bonsaiviking Aug 27 '12 at 2:25
    
I don't know what the problem was, but it's definitely an issue with Windows. I installed Metasploit on a Backtrack VM and it works fine. –  Pickle Aug 28 '12 at 0:51
    
see also superuser.com/q/737431/4227 –  AShelly Sep 29 at 21:34

3 Answers 3

sudo nmap [options]

Fixed it for me. For some reason nmap wants root, then ping works as expected.

Protip: sudo !!

share|improve this answer
    
Being sudo also works on my system, however, it's problematic because I execute nmap through a PHP script which by default does not have elevated rights :-( –  Eugene van der Merwe Nov 17 '13 at 9:34

If you are using a recent (version 6.00 or 6.01) version of Nmap, this may be related to a known bug. Try running with --unprivileged, which will break some features of Nmap, but ought to work for port scanning. Alternatively, use the output of nmap --iflist to identify the interface name (e.g. eth1) that should be used for the scan, and pass it to Nmap with the -e flag, like so: nmap -e eth1 --other --args targets

share|improve this answer

I had the exact same problem in my Windows 7 Enterprise x86.

When I added the -e option as bonsaiviking explained, it works well, though too slow. Additionally, I found it happens when your PC has multiple network adapters such as VM network (VMware Network Adapter VMnet8).

After disabling the vm8 adapter it works well without the -e option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.