Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I get the following error while accessing my hard drive (NTFS partition). It was an internal hard drive, it started giving issues due to some corrupt boot sector. So I brought a casing for it and started using it externally. It worked a few times, but then it started giving the following error(on Linux Mint):

Error mounting: mount exited with exit code 13: ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

I did try running chkdsk /f on it, but still no use. Windows doesn't even recognize the hard drive, but Linux Mint atleast shows the above error and does list the drive alongside other partitions of the internal hard drive.

share|improve this question

I had an almost identical error message and was able to fix it using "ntfsfix" which was already installed on my Linux Mint (Debian Edition):

sudo ntfsfix /dev/sdc1

You will need to make sure your device is sdc1 or edit the above to the correct value (hint: take a look in /var/log/syslog).

Here is the output from ntfsfix in my case:

$ sudo ntfsfix /dev/sdc1

Mounting volume... $MFTMirr does not match $MFT (record 0).
FAILED
Attempting to correct errors... 
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... FAILED
Correcting differences in $MFTMirr record 0...OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdc1 was processed successfully.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.