Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running the following command:

7z.exe a -t7z -m9=LZMA2 test.7z test.txt

However, I get this error: System error:The parameter is incorrect. The error only occurs if I use the -m9=LZMA2 or -m9=LZMA switches. If I remove it, it works perfectly fine. What am I doing wrong?

I am executing the command from Windows XP, 7 and 2008.

share|improve this question
    
Your command works on my end - which version of 7zip are you using? –  zb226 Aug 26 '12 at 21:26
    
@zb226 - Version 9.20 –  PeanutsMonkey Aug 26 '12 at 21:35
    
Weird, that's the same version I'm using... If I change LZMA2 to something bogus, like xyz, I get the The parameter is incorrect. error... And using LZMA works too, btw. –  zb226 Aug 26 '12 at 21:41
    
@zb226 - Would anything else cause the issue? –  PeanutsMonkey Aug 26 '12 at 23:16
    
Tried it on another machine today and it works there as well (exactly as stated above). Did you download it from here? For reference, the MD5 hash is 42badc1d2f03a8b1e4875740d3d49336. –  zb226 Aug 27 '12 at 10:30

1 Answer 1

I believe you're misinterpreting the meaning of the -m? switch... -m9=lzma2 doesn't give you better compression than -m0=lzma2, that's the -mx switch.

Try this instead:

7za a -t7z -m0=lzma2 -mx=9 archive.7z files

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.