Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a ThinkPad T400 with Windows Vista Ultimate.

When I try to go to Standby, I often get a DRIVER_POWER_STATE_FAILURE stop code.

At first, WinDbg flagged it as the Citrix Deterministic Network enhancer. After downloading the latest version from Citrix, WinDbg flags the latest memory dump as VMNetSrv.sys.

However, I already have the latest service pack of Virtual PC 2007.

Does anyone have any suggestions?

share|improve this question

4 Answers 4

Ideas for resolving sleep problems:

  1. Look in your BIOS for the suspend ACPI options and try to switch modes among "S1 and S3", "S3" etc.
  2. Turn off Hybrid sleep, see explanation here (for vista, but is the same)
  3. The hibernation file is sometimes disabled by disk cleaning, to restore do in cmd run as administrator "powercfg -h on".

Note: Any of the above manipulation that doesn't help should be undone.

In Windows 7 you can use the following command to troubleshoot sleep problems and return a detailed report:

powercfg -ENERGY

image

share|improve this answer
    
Unfortunately, I've tried all of those measures and I'm using Windows Vista. Perhaps this would be a good reason to use W7... –  Zian Choy Feb 2 '10 at 16:14

Try using NirSoft BlueScreenView, it's supposed to pull all the information you could ever want into once place for each blue screen, might shed some more light on the matter.

share|improve this answer
    
It doesn't provide any info that WinDbg doesn't already give. –  Zian Choy Sep 27 '09 at 11:00

Have you checked if there are any BIOS updates for your ThinkPad?

Even though your error points to VMNetSrv.sys, the actual problem could be deeper than that, but only showing up at the topmost level (your vm).

I'm not sure what your 'network enhancer' does. But along with checking for the latest BIOS, I would also make sure all of your network adapter drivers are updated to the latest.

If you STILL get BSOD, try removing variables. Such as disable all of your network adapters and see if it still BSODs, if it does, then see if it BSODs without Virtual PC installed. My guess is that the issue will disappear if you disable the network adapters.

Also, there might be two ways to disable the network adapter, one is in the adapter control panel settings. The other is in the device manager itself, where you can actually disable the device directly (which might prove to be better results) because then no driver is even loaded for it.

Update on your results for more troubleshooting info.

share|improve this answer
up vote 0 down vote accepted

I solved the problem by switching to Windows 7.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.