Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have setup my Notebook to dual boot for CentOS 6.3 (64-bit) and Ubuntu 12.04 (32-bit) and both have been configured for ntp (network time protocol) with proper time zones (India).

But they are showing an exact time difference of 5 1/2 hours. Only one of them is showing the proper time. Why is it so? I made sure both OS are configure to ntp and the time zones are set proper.

share|improve this question
up vote 2 down vote accepted

Use ntpq -p to check that NTP is operating. Remember, NTP is designed for continuous operation and may take considerable time to settle at an accurate value.

Note that NTP software doesn't like making huge adjustments in time so it is worth checking that both operating systems have the same ideas about how the motherboard RTC is interpreted. Typically this is used at startup to set the Linux system clock.

e.g. in /etc/default/rcS

# Set UTC=yes if your system clock is set to UTC (GMT), and UTC=no if not.

If the two OSs disagree, you could get the symptoms you observe. But note different distros have different config files so I'd read relevant man pages carefully.

share|improve this answer
Even after setting UTC=no in /etc/sysconfig/clock file on CentOS, there was no improvement.… – Praveen Sripati Aug 27 '12 at 11:00
@PraveenSripati: did you reboot? – RedGrittyBrick Aug 27 '12 at 11:06
Just to make sure I rebooted again, and it's the same problem. – Praveen Sripati Aug 27 '12 at 11:11
Not sure why the changes to CentOS were not getting reflected, so I made UTC=yes and hwclock -w on Ubuntu and both the times show properly. Thanks for your time and tip. BTW, how do know so much :) – Praveen Sripati Aug 27 '12 at 13:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .