Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had the same mouse for a while, and it's been working fine until one day, it started giving me a message about a device not working properly. I tried updating the drivers, and re-installing, I even deleted old drivers in case my computer should be a little confused. It never made a difference, and my mouse seemed to be working just fine despite getting the permanent error in my device manager, I looked it up several times online, but I never found anything I could actually use, when I go to official websites, I always get the same response "plug in so so into a different place - drivers - install silverlight before you can watch this tutorial, try it on a different machine". so I gave up on that.

But now is where I have a real problem, lately, my little strange error evolved into a fullblown Error 24, and my mouse is starting to turn on and off randomely, especially when it is being used, but I do hear it go "badum..dadum" when I'm off doing something else. when I looked up error code 24, I really didn't find much other than it meaning:

Code 24 This device is not present, is not working properly, or does not have all its drivers installed. (Code 24) Cause

The device is installed incorrectly. The problem could be a hardware failure, or a new driver might be needed.

Devices stay in this state if they have been prepared for removal. After you remove the device, this error disappears.

But, I have tried uninstalling the device entirely several times, and it'll go right back to its previous state with error 24, and turning on and off randomely. what do I do? I cannot afford taking it to a repair place, I can't really afford a new mouse either, I refuse to buy cheap ones as I am a gamer, in need of more than 3 buttons, and a good grip is important.

Could there possibly be some confusion in the registry? I do remember having gotten some early problems after I converted my vista to windows7. But I hardly dare going in there unless I'm 100% certain of what I'm going for, and I can honestly say I am at a loss here.

Edit: it is a USB mouse we're talking about here. MX™518 Optical Gaming Mouse (logitech)

Edit2: I am seeing no rupture, so it must be on the inside of my mouse, or inside the rubber, protecting the cable, that would be really inconvenient to search for

share|improve this question
    
Are we talking about a USB or PS2 mouse? –  Ramhound Aug 27 '12 at 11:40
    
@Ramhound It must be USB. PS2 devices don't notify PnP system. –  Axeman Aug 27 '12 at 11:52
    
@Axeman - True....It also could be a PS2 mouse but an adapter is being used. Without spending money using another USB 2.0 port might be lead to some sucess. –  Ramhound Aug 27 '12 at 12:26
    
@cj. seems like you've lost the cookie identifying you, please register your account to regain control over your account –  Sathya Aug 27 '12 at 12:34
    
About your edit2: mouse cable damages are almost never visible from the outside. And FWIW the 1st generation of MX518 is actually one of the mouses that broke in that way. –  Axeman Aug 27 '12 at 13:00

2 Answers 2

It happened to me more than once, but the cause was the cable that broke from the motion stress.

A spot with my faithful Weller welder always solved the issue.

share|improve this answer

Does the mouse work on another computer with Windows 7 installed? Please confirm with the hardware manufacturer to see if the mouse is fully compatible with Windows 7. Also, you can check the issue with another PS2/USB mouse to see if it works.

You can try to update drivers for this device. Is the mouse listed in Device Manager? If so, please right click it, click "Update Driver Software…", and then click "Search automatically for updated driver software". Follow the wizard to see if the issue can be resolved.

Basically this code means that the device was not found (for example, it is missing or is not working properly).

If the device still does not work, make sure the device is connected to your computer correctly. For example, make sure all cables are correctly installed, or that the adapter cards are properly seated in their slots.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.