Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop running Mint 13.

I have it hooked up to a 30" monitor and have no use for the laptop being open, so I put it on a shelf and close it. When I do that, the monitor goes blank. The power manager does not have an option for doing nothing when the lid is closed. The options are "Blank Screen", "Suspend", and "Shutdown".

Is there a way to make the laptop not go to a blank screen when the lid is closed?

share|improve this question
    
It sounds the simplest solution would not to fully close the laptop case. –  Ramhound Aug 27 '12 at 13:10
1  
@Ramhound Yeah. I was looking for a better solution than that. –  ewok Aug 27 '12 at 13:44
add comment

2 Answers

This worked for me on a Dell Inspiron 1501 with Linux Mint 13 Mate 32bit.

  • Open Configuration Editor (mateconf-editor)
  • Goto: apps/mate-power-manager/buttons
  • Change lid-ac from "blank" to "nothing"
  • Open up Screensaver Preferences / Power Management at the bottom.
  • Click make as default (Make sure "When laptop lid is closed" to "do nothing")
share|improve this answer
    
I tried this. it allows the "Do Nothing" option to show up in the menu, but it still blanks the screen when the lid is closed. –  ewok Aug 29 '12 at 18:24
    
works on HP-5330m as well ...thx –  equivalent8 Dec 6 '12 at 9:16
    
I still didn't get the "Do Nothing" option in the screensaver->power management settings. When I close the lid, the external monitor switches off; but waggle the mouse/press any key and it comes back again. –  user190759 Jan 17 '13 at 17:57
add comment

The problem is caused by design of the Lid close event handling script of Mint 13. For whatever ('*') state, the instructions execute a 'screenBlank' instruction set. It's clear that it's an assumption they had taken for granted. The following is just a workaround.

Note: You might have to use sudo or be root to perform this.

Open the file /etc/acpi/lid.sh There find the line . /usr/share/acpi-support/screenblank Comment that out with putting # before it. The issue should be resolved

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.