Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Cygwin/X installed on a Win7 box. I also have an Ubuntu VM running on the Win7 host.

If I do the following:

  1. Start Xming on the Win7 box
  2. Start mate-terminal under Cygwin/X

then mate-terminal starts up with very crappy-looking fonts and a blinking cursor. (I'm using "Monospace 10" in mate-terminal.)

If I then do:

  1. Use putty to ssh into the Ubuntu VM (fowarding the X connection)
  2. Run gnome-settings-daemon on the Ubuntu VM

then the fonts in mate-terminal suddenly become much better looking and the cursor stops blinking (probably because I've configured it that way in Ubuntu.)

Question:

How can I get the better-looking fonts and the ability to set cursor-blinks option for mate-terminal under Cygwin/X without having to run the Ubuntu VM?

FWIW, I have Xming-fonts-7-5-0-4 installed.

Update: Starting Xming with '-dpi 101' as suggested here helps, but the fonts are still not anti-aliased.

Update: Figured out the cursor blink problem... added this:

    <entry name="cursor_blink_mode" mtime="1346104804" type="string">
            <stringvalue>off</stringvalue>
    </entry>

to the file ~/.mateconf/apps/mate-terminal/profiles/Default/%mateconf.xml when mateconfd is not running.

share|improve this question
add comment

1 Answer

You may need to create the configuration files for GTK2 and GTK3 in the Cygwin environment, in order to make the applications load and use them, as there is not a settings-manager running on Cygwin.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.