Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Debian server which I've set up file ACLs on. However, ACLs on the encfs filesystem I've made don't seem to be handled properly. The mount directory is setguid and has a default:group::rwx ACL entry, but files and directories I make in the root are set to be non-group-writable. I've also tried making a directory on the filesystem and manually setting the default ACL on it, but files and directories I make in that directory don't have group write permission either.

I think I'm missing a mount option or something (I had to change /etc/fstab to add an acl option for the root filesystem when I set up ACLs), but I get a fuse: unknown option error from trying to mount with acl or extended_security.

The exact command I'm using to mount the filesystem is encfs -o allow_other /home/blackl/.this /home/blackl/this.

How do I get the encrypted filesystem to handle ACLs properly?

share|improve this question
    
AFAIK from a quick Google search Fuse, and anything based on it doesn't support ACLs. If you need ACLs, you probably need to look at DM-Crypt, Truecrypt, or something else. –  Zoredache Aug 28 '12 at 0:58
    
Okay…how do I encrypt a directory using dm-crypt? –  Blacklight Shining Sep 1 '12 at 0:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.