Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been trying to set up two TP LINK wireless N cameras that I bought so that I can see them remotely.

I've set it up so that each has it's own ip address (192...105/192...106) and I can access them if I type that into the browser of a local computer

The thing is that I don't know how to access them from another remote PC.

My current setup is a a each camera connected to the router which then connects to the modem.

When I set up the Dynamic DNS, and I access the "webpage" for my IP through a remote computer, it just goes to the configuration page of the modem. I have no idea how to make it go to the router or to the cameras.

the router has its own ip range of 192.168.1.x while the modem has 192.168.2.x

To access the cameras I type into the web browser: 192.168.1.114:100 on the local computer

but I have no idea how to get there through the webpage of my Dynamic DNS remotely.

share|improve this question
    
For anyone else trying to do the same thing. I ended up bridging my router with my modem. Then (since my router has built in DDNS updating) I set it up for that, forwarded the appropriate ports for each camera and was able to access the cameras through "mywebsite.com:XXXX" where XXXX is the port number for the camera. –  Mike Szp. Jul 25 '13 at 13:46

3 Answers 3

up vote 1 down vote accepted

Mike,

My guess is that your Modem has router capabilities and it would need to be bridged with your router. Once bridged you would then be able to port forward your router to the correct internal IP address and then port 102 in your example would be accessible by typing in the host.domain.com:102 or your IP address 72.156.52.12:102.

You have another option and that would be to set up port forwarding in your modem to allow port 102 to your router, what you said was 192.168.1.x then in your router port forward the port 102 for the camera's internal IP address.

TP-Link routers have an integrated DDNS that supports No-IP.com. If you get the port forwarding set up correctly, it should work flawlessly.

Let me know if you have any additional questions.

-Natalie Goguen -Online Marketing Manager- www.no-ip.com

share|improve this answer

I do suspect you're doing it wrong, and that there's a simpler, more sensible option to this.

You have a local IP address scope (192.168.x.x) and a global IP address. Your dynamic domain links to the global IP address at your router. Any attempts at DNS would end up linking there. There's almost no way around it.

If its always the same remote computer, set up a VPN at the site with the cameras and connect through it - it would make the remote site part of the local site's lan. I'd go with openvpn here, but there's many options.

If its different remote computers you could probably use something like pagekite, which is essentially a reverse proxy.

If the cameras supported IPV6, which I doubt, that would work as well.

share|improve this answer

You need to set up port forwarding on your router. Check your routers manual on how to do this. You set up dDNS, so you probably understand that you have only one public IP address. When you connect to that address, either by IP or by dDNS, you are connecting to your router, as it is the device with the public IP. You would use the routers port forwarding menu to pass the incoming connection to a device on your internal LAN, in your case the camera.

share|improve this answer
    
but the thing is it connects to my modem's page not my routers. I have the ports of the cameras forwarded, lets say the camera used port 102 and my ip was like 72.156.52.12 how would I access it from the web? –  Mike Szp. Aug 28 '12 at 18:57
    
A web browser defaults to port 80 if you just type in 72.156.52.12. That is why it is going to your routers web page. You need to type 72.156.52.12:102 to get to the camera. –  Keltari Aug 28 '12 at 19:01
    
but again, it's not going to my router, it's going to my modem instead. –  Mike Szp. Aug 28 '12 at 21:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.