Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install a package that depends on python-keybinder and hence on libkeybinder. When I run makepkg for libkeybinder, it starts and after sometime I get the following error:

checking for XkbQueryExtension... no
configure: error: Could not find XKB
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build libkeybinder.

I tried checking the pkgbuild but wasn't able to find anything. :( Is there a workaround?

share|improve this question

Which AUR package? If http://aur.archlinux.org/packages.php?ID=41551 , then it builds fine here. Did you read the comment thread? It looks like it also depends on pkg-config, which should be in base-devel, and XkbQueryExtension is a part of libx11, which you'll also need.

share|improve this answer
    
base-devel and libx11 are installed. I am trying to install pythonkeybinder – Nihar Sarangi Aug 29 '12 at 8:24
    
lib32-libx11 could possibly be a dependency, but that would be odd. There are, however, multiple AUR packages for libkeybinder, the library you said was failing. Is the one you're trying to install the one I linked to? If so, please post the full output from a clean attempt at building via makepkg -- use makepkg -s | curl -F 'sprunge=<-' http://sprunge.us if you need a paste service. – jeremiahd Aug 29 '12 at 9:54
    
Yes, it's the same library that I am trying to install. This is the output I got by running makepkg pastebin.com/XKmQcR2J – Nihar Sarangi Aug 29 '12 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .